Fairphone Open 17.06.4 (Android 6.0) release

I’m still on LP. Tell me how to check it, :slight_smile:

Do you have an app showing (actual and) cumulated cpu frequency? Like kernel adiutor or cpu spy?
Reset statistics and do some moderate work, like reading web pages, where reading far outweighs browsing. Something like that, basically, looking at the screen and not doing too much else. Then have a look at the statistics. If my theory is correct, you won’t have the majority at 1728, 1496 and 1190, but lower. If you have kennel adiutor, just looking at the statistics for cpu will give you a feeling for the cpu range. I often have to cores switched off, but the rest does not normally go below 1190. Iirc, it went down to 300 for notable time spans

Yup, :+1: to your theory

1 Like

But how could the hardware fail if every worked fine? I have no money actually for spare parts.
Okay battery and bottom module are not so expensive. But 11€ for shipping is too much. And when I get the spare parts and it doesn’t help I only waste money.
Now I try to charge my phone for one day. But I think the red flashing LED will not stop.
I should contact support again. :frowning:

I used kernel adiutor to lower all special frequencies (except for Max), so far it does not seem to lag, but phone is notably cooler

Because electronics occasionally fail.
About bottom module, see for example here:

You shouldn’t need any. If you didn’t do anything wrong it should be covered by warranty.

Make sure your charger has at least 1A output (which is minimum recommendation by Fairphone any way). A weaker charger may not deliver enough power to overcome a deep discharged battery.

1 Like

I experience the same problem of very distorted sounds, but for me it occurs when I’m listening to music with the phone (maybe it also happens during calls, but I had only few calls after the update, so I do not know at the moment). Since the problem occurs with the phone’s speaker and with headphones and it just started after the update, I expect it to be a software problem.

It looks like a known software problem and the fairphone team is already on it:

https://bugtracker.fairphone.com/project/fairphone-fairphone-os-android-6/issue/47

To me it seems the volume or loudness during a phone call just got better compared to the prevoius version of Android, where the sound volume was just too low to understand the person on the other end even with loudness turned to 100%.

Another issue:

with the new OOS version I’m sometimes unable to answer calls. Display goes on, I can see and hear the call (sometimes even vibration works - not everytime though… another issue that started with the update to android 6) but wiping to the answer-call symbol has no effect. This happens with approx. 2 out of 10 calls.

Workaround: calling back ^^

Not sure if it’s worth anything, but here’s my report of my second attempt to install Marshmallow:
I re-downloaded all the files necessary, just in case, and made a backup through TWRP. Then I disabled the GravityBox module in Xposed, as that requires a different version in Marshmallow and I was hoping that might’ve caused the first update failure. Then I had a very smooth installation process, flashing the OTA file, followed by OpenGAPPS and Xposed, wiping Cache and Dalvik, and finally rebooting the system. Was very smooth, indeed, just like last time.

Optimising 144 apps takes some time, but it was a lot faster than before for some reason. However, I got caught in the cyclic reboots shortly after. It seemed like the phone freezes every time when a message pops up, asking me to allow Xposed access to write on the external sd card. I took the battery out, let the phone cool off (phone gets insanely hot during the entire process) and took the sd card and my second sim card out. After turning it on again it needed to optimise 20 apps again. Then I noticed that the battery charge dropped from 79% to 26% and was actually discharging 1% per second. I quickly connected the phone to the charger and it was back to both: being extremely hot and caught in the good old cyclic reboot.

Every time the phone boots up I can actually use the phone for a couple minutes before it freezes and it looks like it might be the fault of Xposed. Every app seems to open up just fine (in the way app like to open up directly after booting up), except for Xposed. Every time I try to open the Xposed app the phone freezes instantly and reboots shortly after. Maybe the cyclic reboots have to do with Xposed? Does anyone have a working Marshmallow with Xposed to rule that out?

Anyway, quite annoying long procedure, looking forward to downgrade again later on… :cry:

Yep, works fine for me. No GAPPS, though, just Xposed, XPrivacy and microG.

Just to make sure: You’ve downloaded SDK23 of Xposed for usage with Marshmallow, right? SDK22 like it was for Lollipop won’t work.

Hello, upgrade from fp2-sibon-17.04.0-ota-userdebug.zip to fp2-sibon-17.06.4-ota-userdebug.zip. Downloaded OTA file and xposed-v87-sdk23-arm.zip to the sdcard, reboot into TWRP, made a backup (!!!), flashed OTA file and Xposed, wiped Cache and Dalvik, rebooted. Everything ok, but then, similar to @leVin42 : half a dozen reboots later, no stable phone, everything is there, but when I have to put in the code for the simcard, it freezes immediately or a few seconds later, then reboots a few minutes later… no issue found… downgraded with TWRP (!!!), everything is back again. I had no problem with the battery. So what should I try now? First time I do have a serious problem with FP Open.

Damn, would’ve been at least a reason why it doesn’t work for me…

Yep, I was using SDK 23.

Now I’m back to Android 5.1 and lost all messages I got sent via whatsapp while my phone was caught in the reboot cycle. Very annoying stuff, just hoping I’ll be able to use Android 6 at some point soon!

I don’t know, maybe just use the old Open OS until someone comes up with a solution or Fairphone releases a new version, I guess. Slightly inconvenient, but after two attempts that’ll be my solution for now, I guess.

This sounds a lot like this unsolved bug:

However, doing a handful things at once like a major upgrade of a system (from 5.1 to 6.0) plus upgrading a quite complex mod (like Xposed) sounds like a terrible idea. You may want to split this into several subtasks after each one you can assure your system boots and works, and if not, isolate better your problem. Here is how I’d do it:

  1. Uninstall Xposed.
  2. Boot into your clean system and upgrade to Marshmallow
  3. Boot into Marshmallow and make sure everything works as expected (if not, refer to the bug linked on the top)
  4. Install Xposed Framework for Marshmallow (SDK 23)
2 Likes

X-posed in Marshmallow worked fine for me but, after a few days, I have downgraded to Lollipop again. My battery was draining very fast apparently due to the proximity sensor since it was better when I stopped Gravity Screen (similar to Wave Up and working in Lollipop with Explit’s workaround). I had also problems with a very unstable Wi-Fi connection that I could not fix.

1 Like

Thanks @esther. However, I’m already dealing with a ridiculous fast draining battery (no, cannot be the proximity sensor in my case!) and therefore might give it another go like @Roboe suggested.

1 Like

Hello everyone!

I have a quick question… If I come from lineage os, can I install use FairPhone open just through twrp or I need to do something else?

Merci @Roboe I’ll try this!

1 Like

Just for some kind of heads up. I also had reboot loops, while trying to some this i accidentally did a factory reset cos fastboot (yeah, i know. Silly me). But system was stable afterwards. I then sit an “official” factory reset, so i was able to encrypt my data partition again
So, for a week now, I’m on mm open os with xposed, opengapps and encrypted. No further problems, phone runs fine
Excerpt for the cpu scheduler, which let’s run the cpu soon too high frequencies, in my opinion. Pasted here, and also reported on the bugtracker, which probably leads to give battery usage while screen is on. Idle usage is fine, but I’m also using greenify

4 Likes