English

Fairphone Open 17.06.4 (Android 6.0) release

I resolved (apparently) this problem by taking the second SIM off the phone… phone now is cool to the touch and battery life increased significantly… (check out the topic about battery life). Do you use 2 SIM cards?

Bug?

After I navigate through applications and press home button again my phone goes to the far left screen every time… regardless where it was before I pressed menu button.

Anyone else experiencing this?

No, I only have one sim card.

How about SDcard? if yes, does situation improve if you take it out?

This i did not check. Will do this weekend

A post was merged into an existing topic: FP2 random reboots - see first post for workarounds

I don’t know any Fairphone user around me.
If I use the same charger, my FP2 is still flashing all the time.
Even reflashing didn’t helped.
First it seems reflashing was successful, but nothing changed.
I have absolutley no idea what I should do. :frowning:

If resetting the battery didn’t help (note that some users reported they had to kickstart the battery twice; see #batteryguide ) then, as I said above, I would assume faulty hardware.
If the battery worked fine before, my guess would be that the bottom module rather would have sudden failure than the battery, so this is where I would start. Yet, it is also possible that a battery is completely deep discharged and dead. Either way, in case of a hardware defect I would recommend to contact support.

After upgrade to Fairphone Open 17.06.04 my apps cannot access external SD card (which I have set up as portable storage).
I have checked platform.xml and there has been no WRITE_EXTERNAL_STORAGE section after upgrade!
I added the permission as discussed many times before (SD Card no writing permission in FP2), rebooted - but no access granted to SD card. I have no idea how to proceed.

1 Like

If an app can access the sd card seems to depend on whether apps have implemented storage access provider or not.

See above:

No difference of i remove the sd card. Still the lowest frequency stays at 1190MHz and nearly never goes below that.
Anyone knows someone who’s still on lp and can check?

Thanks for the reply, but unfortunately the answer given by Johannes did not solve the problem with my Open Camera installation. I have tried to activate “Use Storage Access Framework” and the screen showed my SD card. Strange thing is it shows the SD card having 0.00B free space - even though there are more than 50GB available. And I can not toggle “Use Storage Access Framework”.
I will search for “storage access provider” for my other apps (for example I am using Total Commander) on the Internet for a solution. Thank you for the hint!

I’m still on LP. Tell me how to check it, :slight_smile:

Do you have an app showing (actual and) cumulated cpu frequency? Like kernel adiutor or cpu spy?
Reset statistics and do some moderate work, like reading web pages, where reading far outweighs browsing. Something like that, basically, looking at the screen and not doing too much else. Then have a look at the statistics. If my theory is correct, you won’t have the majority at 1728, 1496 and 1190, but lower. If you have kennel adiutor, just looking at the statistics for cpu will give you a feeling for the cpu range. I often have to cores switched off, but the rest does not normally go below 1190. Iirc, it went down to 300 for notable time spans

Yup, :+1: to your theory

1 Like

But how could the hardware fail if every worked fine? I have no money actually for spare parts.
Okay battery and bottom module are not so expensive. But 11€ for shipping is too much. And when I get the spare parts and it doesn’t help I only waste money.
Now I try to charge my phone for one day. But I think the red flashing LED will not stop.
I should contact support again. :frowning:

I used kernel adiutor to lower all special frequencies (except for Max), so far it does not seem to lag, but phone is notably cooler

Because electronics occasionally fail.
About bottom module, see for example here:

You shouldn’t need any. If you didn’t do anything wrong it should be covered by warranty.

Make sure your charger has at least 1A output (which is minimum recommendation by Fairphone any way). A weaker charger may not deliver enough power to overcome a deep discharged battery.

1 Like

I experience the same problem of very distorted sounds, but for me it occurs when I’m listening to music with the phone (maybe it also happens during calls, but I had only few calls after the update, so I do not know at the moment). Since the problem occurs with the phone’s speaker and with headphones and it just started after the update, I expect it to be a software problem.

It looks like a known software problem and the fairphone team is already on it:

https://bugtracker.fairphone.com/project/fairphone-fairphone-os-android-6/issue/47