Fairphone Open 16.09.0 is now available

Probably. A normal app cannot access /cache like that, AFAIK

Well they have implemented a check if they are a priviliged app and otherwise use a superuser library for doing things.

1 Like

Hi there everybody,
maybe I found a bug today concerning Truephone.
Since 3 days I am running FOS 16.09.0 installed by the Fairphone updater without any special configuration, rooted. But I got Truephone installed since months. With previous FOS-versions I used truephone and the build-in phone app simultaneously as I still did until today. Today I reused the “left desktop” with “letzter Kontakt” and “am häufigsten kontaktiert” since a long time. I can’t call any of the contacts there with both sim. When trying to call after choosing one of my two sim it says “Anruf nicht verbunden”. Same result when using “Kontakte”.

Anybody else with the same problem?
Do I have to uninstall truephone?

Have a blessed sunday
Barney

If you are interested, I have uploaded the patch to my personal GitHub: https://github.com/z3ntu/FairphoneUpdater/commit/01cb543cc212d7c0c8a8a761ef226583edc298af . I’ll try to submit the patch to the Gerrit instance for Fairphone (but the Google login is currently broken so I can’t log in)

1 Like

When the choose SIM dialogue comes up, try waiting a little longer before choosing a SIM card. Five seconds should do it, though I recall someone mentioning they had to wait a little longer. See also the topic over here or Fairphone support’s software issue report.

1 Like

Yeah, I agree, hence: @anon12454812 Have you recognized @z3ntu’s post? :wink:

@moderators: It might make sense to split @Roboe’s and @z3ntu’s bugfix discussion to a new thread?!

1 Like

Thanks, Johannes for answering.
Since I know the Two-SIM-Bug I always wait for the return of the dialogue after it disappeared.This is not my problem.

The build-in phone app doesn’t work any more for phone calls. This is the point.

Did you try to deactivate or temporarily uninstall your third party phone app?
This way you could check if your problem is caused by a conflict of the two apps.

For me also the update worked flawlessly. Encrypted, opengapps and exposed module. This time i even remembered in time to get the up-to-date version of opengapps beforehand :slight_smile:
Unfortunately, the issue with the proximity sensor (no deep sleep if used) isn’t fixed. But one probably couldn’t expect it this fast :wink:

Did you reset the proximity sensor?
Go to 'Settings’
scroll down to 'Maintenance’
and tab on “Proximity sensor”

Update seems fine.
But again something happened while updating which I already had several times: Automated updates pop up, I say install, it dls the files and then is stuck in a waiting loop. Killing the updater works sometimes, this time I had to restart the phone because it was completely stuck. Restarting the whole process once or twices does the trick.

If this issue is already known and mentioned somewhere just ignore this. Otherwise I just wanted to mention it, doesn’t seem to to a lot of harm, though.

No, i didn’t, because i would not expect calibrating shaving the behavior… But you’re right, for completeness i will do this and report the results here.

Edit: as I expected, the bug message was too late. Phone still does not deep sleep if proximity sensor is used while display is off. Hope for 16.10 :slight_smile:

Update went fine, although if I had not rebooted my phone I would have probably had to wait until thy kingdom come for an update notification. FP Updater urgently needs an option to manually check for updates (bug report already filed).

1 Like

I uninstalled truephone. Restarted the phone. But I can’t call anybody any more with the build-in phone-app neither from my contacst or direct dialling! But my phone can still be called by others.
This is a serious problem! Does anybody else have the same problem?
I shall now check, how I can switch back to 16.08.0 if nobody has a fix for me.

Try to delete cache and data from the phone app, in all apps - settings - apps - all - dialer.

I really really doubt that it is related to 16.09, because if so, others should be affected as well.

1 Like

Thanks @freibadschwimmer, but including restart that didn’t change anything. I also had a few sudden reboots. Maybe it is that antenna issue…

updated via the updater - everything went fine - at least I hope so there were some scary red lines “couldnt find …” and “couldn’t create …”

I had to start the update twice, and then it was installed - in spite of some “couldnt find bla” as well.
I also installed the latest gapps and flashed xposed again, and everything seems okay so far.

Is it normal to lose my google account when flashing a new version of gapps?!

For me not… No. Did you reboot into Android before flashing gapps? Maybe a system without gapps somehow resets the account, as no “provide” for the account is available?

Yes, I tried the existing gapps on my phone first, rebooting into Android, so I guess that’s what caused it. Next time I’ll download the new ones before the update and flash both. :slight_smile: