English

Fairphone does not boot up anymore (bluescreen)

First of all, to notify users, just type “@” before their names, e.g. @Twist. :wink:

Secondly: Here is an extract from the link, I suggested above:

[quote]###How to Extract ADB backups With ADB Extractor & Manual extraction with openssl
LINK: http://sourceforge.net/projects/adbextractor/

  • Download the zip file.
  • Extract the abe.jar
  • JUST COPY abe.jar INTO DIRECTORY WHERE YOU HAVE adb backup .bak or .ad
    OR .whatever FILE AS LONG AS IT WAS MADE WITH adb backup (OR MAYBE AS
    LONG AS IT WAS JUST MADE WITH adb)
  • JUST OPEN CYGWIN INTO DIRECTORY AND RUN:

java -jar abe.jar unpack backup.bak backup.tar [password][/quote]

So, if you made the .backup-file with adb, then it should get converted into a “.tar”-file, which can be extracted using e.g. 7-Zip.

Thanks @Stefan for the quick reply! (and letting me know how to notify users ;-). I created the .backup file in the recovery mode of my fairphone. Then, I reset the phone to factory mode and subsequently restored my user data. The result is, as describe previously, that the phone gets stuck again when booting (blue start screen). So I tried to open the .backup file, which I have on SD card, with the abe.jar script you suggested, however, without success. But, if I’m not mistake, this would only work if had created the backup file with the Android Debug Bridge (adb), right?

If so, could I restore the user data in the recovery mode of my phone and then access the phone as described here enter link description here http://forum.xda-developers.com/wiki/Fairphone_Fairphone/Guides in chapter 9.1? Then, I would create another backup file (with .ad ending), which could be turned into a zip-like file using the abe.jar script. From this file, I could finally extract individual files, such as pictures. Does this make any sense?

Sorry for my “thinking aloud”, but I need to get this straight. Thank you very much in advance!

This should work, if adb recognizes your Fairphone in Recovery Mode.

Actually, if you manage to install FP OS through Recovery, you’ll be able to boot again and can access all user data, via USB for example. For pictures etc. the most reliable way of backing them up is moving them to your PC.

Does this sound sensible? :woot:

PS.: No need to apologize, it helped me to follow what you have done, and what you are intending to do. :slight_smile:

Thanks again for your help @Stefan! Unfortunately, installing FP OS through recovery did not solve the problem. The installation worked smoothly until the step in which the applications need to be optimized. It takes quite some time, the phone is then rebooting and end ups with a blue screen again. So the situation is still: I have a working phone (when set to factory mode) and a .backup file which I cannot restore nor extract data from. Any further ideas?

Hi community,

having read so much here and gotten indirect a lot of help, I want to share a solution that works for me.

I have repeating blue screens and my phone is due to be repaired (memory chip they say):

Situation: Every time I shut my phone down or rebootet, it was stuck in a blue screen.

Actions: removing all cards does not work, backup doesn notwork (write error) and finally it was solved by a hard reset , losing all my data, which was quite frustrating.

If this happens once; bad luckK, happens twice: damn them, happens more than that: tempted to smash it ;-/

But then the solution by coincidence: remove battery for one night, boot fairphone - tadaaa

works as long, as you do not reboot. Then same procedure. (tested)

At least, I did not lose all my stuff all over again.

Good luck, hope this works for you too.

Daniela

1 Like

Hallo all,

Now, I have my first serious problem with my Fairphone:
I usually use it as an alarmclock. Today morning, it wakes me up normally, and I confirmed the alarm. It should boot, but it doesn’t. Just only the LED was blinking red and I couldn’t do anything. So I removed the battery and tried to start again. But now, the boot process stops at the “Fairphone” splash screen.
Looking around in the forum, I found a thread and this information: https://fairphone.zendesk.com/hc/en-us/articles/201453487-Fairphone-does-not-reboot-Frozen-State- that me leads to the recovery mode - luckily.
But this didn’t solve the problem.
In recovery mode I also found the possibility to backup user data to the external SD card. I hope that worked for me.

My Questions are:

  • About 2 Gigs of user data lead to a 890 MB backup file, is it possible? I’ve got a success message in recovery mode after backup. I think, the data was zipped or something like that. But will it be complete?

  • Which type of file is the backup? Can I open it with my linux box and what might be the password? I cannot remember to enter a password for that in the past.

  • What will be the next step I can do before I have to try to return to factory defaults, which would delete all data on my phone and I’m not sure, that backup worked.

Thank you all for your help,

Ralf

This is the same problem I’ve had for two years now. It occurs every two months, when the phone boots after (or sometimes even before) the alarm goes off.

The backup in the recovery menu (in my case, anyway) just puts the phone back to the previous state: it cannot boot anymore.
I’m afraid you will have to do the factory reset and lose a lot of data… I would recommend to install the paid version of Titanium Backup as soon as possible afterwards.

Hallo danielsjohan,

thank you very much for your reply.

That does not sounds good to me :-/

Luckily, I do not use my phone as the leading device for contacts, calender or mail. But there is some other data, I would like to save. Mh.

Does anybody know, how I can access the backup file I created. That would help a lot. On the other hand, it would be nice, if someone could tell me, witch data was saved in the backup file.

Sounds, that there is a serious risk to use Fairphone as an alarm clock - bad.

Thanks a lot,

Ralf

@cattys,

I tried your solution last night, but unfortunately it didn’t worked for me :frowning:

Ralf

This means that your FP1 is soft-bricked. You should be able to repair the system by manually installing Fairphone OS. User data would not be harmed in this case! :slight_smile:

Hi, Stefan,

thank you for your reply. I tried to install manually, as it is described in that link you added. Alternatively I tried with adb connection. But it failed for me all the time. It did not boot again.

I tried to backup out of the recovery mode, but I cannot read the file. I was asked for a password I do not know. And I don’t know, what kind of file this backup is.

So, my last chance was to reset to factory defaults in weekend.

@danielsjohan told my, that in my case the backup restore would let the phone fail again. So I didn’t try.

OK, I lost some data of my timetracking tool, because of my loosy backup concept, some photos and some messanger chats - bad. But I think, I can restore important data with brain.exe :wink:

Backup, Backup, Backup …

Ralf

2 Likes

hi @myfpuser… Section 9.2 in this thread should work for you if you use it with SP flash tools 3.0, . Because i have also had the same situation. First of all You will have to download SP flash tools v.3. then the binary file in the above thread from FP website. remove battery from FP1. Unzip the binary files you downloaded from the FP website. Run SP flash tools, load scatter file. then click download. afterthis, plug your phone without battery. the SP flash tools should recognize your phone otherwise install driver for your phone. Follow the instruction on the screen. I hope it should resolve your problem. sorry if i could not explain the procedure completely because i have not much time for posting threads.
Please Note: All the data will be destroyed. Use it at your risk. How to backup or how to restore your previous backup, you may read other threads about this because i have no idea how to do this. I hope you undestand

I am also having the same problems here. I have to hard-reset my phone every 1-2 months, basically since at least one year now. It is very annoying and frustrating that there are no proper fixes for this problem!

1 Like

tomas did you ever work out how to open the .backup file?

Since a couple of days my FP1 second batch freezes when turned on: it halts indefinetely on the blue “Fairphone” screen.

I managed to boot in recovery mode as described here https://fairphone.zendesk.com/hc/en-us/articles/201134418.
I wiped the cache, but the problem remains.
I reinstalled the OS with the procedure suggested above but still nothing.

Before resetting all the data I wanted to make a backup but I had this problem: in recovery mode I start the backup procedure and it tells me it’s copying about 12 GB on a empty 16 GB SD card but after a long time it raises a generic write error. I suspect this has to deal with the file system of the SD being FAT32, so the maximum allowed file size is 4GB.

I tryed to format the SD in Ext4 but the recovery mode doesn’t seem to be able to write on such file system.

I also tryed to connect to the phone with adb but the only mode I can obtain is the sideload mode.

What else can I try to make a backup of my data (actually I already have a copy of everything except the pictures) before resetting the phone?
Anybody knows if I can install a different recovery sw using the sideload mode?

Here you go:

@Stefan I ran across that page when googling for a solution but I have two issues on that:

  1. when I do “adb devices” I can’t seem to establish a connection with my phone. The only mode I obtain a positive answer is the sideload mode, but I didn’t find what exactly can I do in sideload mode. So I can’t do the step b) of the procedure (adb shell)

  2. the post is targeting FP1 first edition-repartioned: can I assume that it’s ok to use for a FP1U scond batch?

Thanks a lot for your help

As for the latter: Yes, a second batch FP1U is basically a repartitioned FP1. U stands for Unified Storage. It should work for a FP1U the same as it does for a FP1 (mine for example).

Regarding the first point: You are right, no other adb commands work in sideload mode [Source]. What bugs me the most though is that you could not install Fairphone OS manually. Have you checked again that you used the correct file (Fairphone OS 1.8.7 for FP1U)?

@Stefan I actually succeeded installing Fairphone OS 1.8.7 for FP1U, then I rebooted and the phone said something like “optimizing apps”, a phase that lasted a couple of minutes and gave me great hopes, but then again the phone freezed at the blue screen.

I also tried to install the CWM for the fairphone FP1 usig the sideload mode. It loaded the image but then the phone said “Installation aborted”.
It was just a try, I’m not even sure that this mode is the correct way to install something in the recovery partition… or maybe the image I used was not the right one?

How long did you wait when the blue screen came about? It sometimes takes a very long time (I for once took out the battery because I thought the phone was soft bricked, but I should have waited just some more time…).