Fairphone does not boot up anymore (bluescreen)

This means that your FP1 is soft-bricked. You should be able to repair the system by manually installing Fairphone OS. User data would not be harmed in this case! :slight_smile:

Hi, Stefan,

thank you for your reply. I tried to install manually, as it is described in that link you added. Alternatively I tried with adb connection. But it failed for me all the time. It did not boot again.

I tried to backup out of the recovery mode, but I cannot read the file. I was asked for a password I do not know. And I don’t know, what kind of file this backup is.

So, my last chance was to reset to factory defaults in weekend.

@danielsjohan told my, that in my case the backup restore would let the phone fail again. So I didn’t try.

OK, I lost some data of my timetracking tool, because of my loosy backup concept, some photos and some messanger chats - bad. But I think, I can restore important data with brain.exe :wink:

Backup, Backup, Backup …



hi @myfpuser… Section 9.2 in this thread should work for you if you use it with SP flash tools 3.0, . Because i have also had the same situation. First of all You will have to download SP flash tools v.3. then the binary file in the above thread from FP website. remove battery from FP1. Unzip the binary files you downloaded from the FP website. Run SP flash tools, load scatter file. then click download. afterthis, plug your phone without battery. the SP flash tools should recognize your phone otherwise install driver for your phone. Follow the instruction on the screen. I hope it should resolve your problem. sorry if i could not explain the procedure completely because i have not much time for posting threads.
Please Note: All the data will be destroyed. Use it at your risk. How to backup or how to restore your previous backup, you may read other threads about this because i have no idea how to do this. I hope you undestand

I am also having the same problems here. I have to hard-reset my phone every 1-2 months, basically since at least one year now. It is very annoying and frustrating that there are no proper fixes for this problem!

1 Like

tomas did you ever work out how to open the .backup file?

Since a couple of days my FP1 second batch freezes when turned on: it halts indefinetely on the blue “Fairphone” screen.

I managed to boot in recovery mode as described here https://fairphone.zendesk.com/hc/en-us/articles/201134418.
I wiped the cache, but the problem remains.
I reinstalled the OS with the procedure suggested above but still nothing.

Before resetting all the data I wanted to make a backup but I had this problem: in recovery mode I start the backup procedure and it tells me it’s copying about 12 GB on a empty 16 GB SD card but after a long time it raises a generic write error. I suspect this has to deal with the file system of the SD being FAT32, so the maximum allowed file size is 4GB.

I tryed to format the SD in Ext4 but the recovery mode doesn’t seem to be able to write on such file system.

I also tryed to connect to the phone with adb but the only mode I can obtain is the sideload mode.

What else can I try to make a backup of my data (actually I already have a copy of everything except the pictures) before resetting the phone?
Anybody knows if I can install a different recovery sw using the sideload mode?

Here you go:

@Stefan I ran across that page when googling for a solution but I have two issues on that:

  1. when I do “adb devices” I can’t seem to establish a connection with my phone. The only mode I obtain a positive answer is the sideload mode, but I didn’t find what exactly can I do in sideload mode. So I can’t do the step b) of the procedure (adb shell)

  2. the post is targeting FP1 first edition-repartioned: can I assume that it’s ok to use for a FP1U scond batch?

Thanks a lot for your help

As for the latter: Yes, a second batch FP1U is basically a repartitioned FP1. U stands for Unified Storage. It should work for a FP1U the same as it does for a FP1 (mine for example).

Regarding the first point: You are right, no other adb commands work in sideload mode [Source]. What bugs me the most though is that you could not install Fairphone OS manually. Have you checked again that you used the correct file (Fairphone OS 1.8.7 for FP1U)?

@Stefan I actually succeeded installing Fairphone OS 1.8.7 for FP1U, then I rebooted and the phone said something like “optimizing apps”, a phase that lasted a couple of minutes and gave me great hopes, but then again the phone freezed at the blue screen.

I also tried to install the CWM for the fairphone FP1 usig the sideload mode. It loaded the image but then the phone said “Installation aborted”.
It was just a try, I’m not even sure that this mode is the correct way to install something in the recovery partition… or maybe the image I used was not the right one?

How long did you wait when the blue screen came about? It sometimes takes a very long time (I for once took out the battery because I thought the phone was soft bricked, but I should have waited just some more time…).

I just tried and waited more than 1 hour… should I try and wait even more?

No, one hour should be enough… :blush: BUT WHY DOES IT NOT BOOT??? :tired_face: I don’t understand it…

I fear you won’t be able to recover your personal files… :frowning:

Lost almost any hopes…
I also tryed this:

  • booted the phone in fastboot mode

  • connected to the pc usb port

  • tryed to load the alternate recovery image

    $ fastboot boot cwm-FP1-kk.0.1.img
    downloading ‘boot.img’…
    OKAY [ 0.317s]
    the pc hangs here, while the phone says

    USB Transfering…
    USB Transmission OK Time:305ms Vel:19432KB/s

And nothing happens… think maybe it’s not soft but hard-bricked…

I can’t think of anything else except wiping all the data with the stock recovery function and see if it still works…

1 Like

For the records: wiping all user data made the magic! Now my FP1U is like a brand new one.
The only explaination I can find is that an app was blocking the phone in or suddenly after the boot sequence… is it possible?
Of course I lost all the data that were not backed up somehow.

@Stefan thanks a lot for the kind support provided.

As a side note, I’m quite disappointed by the official fairphone support: I still didn’t get any answer to my request of support dated May 14, 2016, except for a generic reply stating they were experiencing a “temporary spike in requests”.

1 Like

First, good to hear you got your phone working again.

The support seems heavily overworked currently, waiting times around 4-5 weeks seem normal at the moment. Hope these poor guys working in the support will get some help soon…

1 Like

Sorry if what I say has already been said, but I had this problem several times and the only thing that worked for me is reboot, and begin from the beginning. Extremely annoying.

@Stefan: I did it untill step 2; but where do I find the folder /sdk/platform-tools/?

How to restore Fairphone if you softbricked it (OS X, for Windows/Linux see end of section and below)
For this, we will use ADB sideload, an Android developer’s tool to remotely install software on the phone:

1.Download the operating system you wish to install. The original Fairphone ROMs can be found here.
2.Download [developer.android.com/sdk/index.html#download the Android SDK], extract
3.Put YOUR_ROM.zip (YOUR_ROM being the name of your zip-file) in the folder /sdk/platform-tools/
4.Connect Fairphone via USB, boot into Recovery mode (hold volume up button, press power button)
5.Select “Apply Update from ADB”
Open Terminal on Mac, change to folder /platform-tools (pro tip: drag & drop the folder into the Terminal window)
Enter ./adb sideload YOUR_ROM.zip

It’s where you extracted the downloaded Android SDK.

A post was merged into an existing topic: [FP1U] Continued bluescreen after hard reset