Fairphone bricked ? Don't boot and can't access internal/external storage


I just received my FP3 and I planned to resell my old FP2.
It was running LineageOS but I wanted to reinstall the genuine FairphoneOS

But something goes wrong !

I have TWRP installed, but I can’t access to my external storage which contain my iso files (LineageOS and FairphoneOS)
And I can’t mount the internal storage with USB on my computer !

Before to be blocked like this :

  • I tried to install the FairphoneOS official zip, but TWRP doesn’t want to do it : the file “was not correct”, but the MD5sum was good ! Same for LineageOS !
  • so after this, I have tried to reinstall the boot partition with the boot.img file (from LineageOS), and I did the same for the recovery partition (with the recovery.img file)

But now my phone don’t reboot anymore : there is no OS installed and the Fairphone logo with powered by android stay all the time until I remove the battery or press the powerbutton 10 seconds…

I can go to TWRP and do some stuff, but I don’t know how to access to any zip file or iso files !

Do you think my phone is bricked or any issue is existing ?

Have you tried factory resetting the phone in TWRP?

How to you do it ? I have TWRP 3.1.1 and I don’t see the factory reset option…

Wipe - Swipe to Factory Reset

If all else fails …


It’s the “Wipe” button. Hit that, and then do the swipe at the bottom for a factory reset.

Yes I get my FP2 back with this tutorial : 🇬🇧 🇩🇪 ✏ Installing the Fairphone 2 from scratch in case of failure / Komplette Neuinstallation des Fairphone 2 im Fehlerfall

Thanks to all for helping !


Just as a sidenote: the zip file of FairphoneOS is not intended to install via TWRP but must be unzipped on a PC and contains all files to flash it via fastboot from there.

1 Like

Yes I tried this way, but the CLI command with fastboot enabled didn’t work, and I didn’t understood why… That was the begining of my “bullshit” with boot/recovery partitions deletion…

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.