Fairphone 5, Netflix in SD

Both me and my mother (who also has a Fairphone 5) only get 480p (SD) in the mobile Netflix app. In the app it says there is only widevine L3 support. But when I look in an app called “DRM info” it states the Fairphone 5 has L1 wich should permit hdr and full HD, and higher bitrates.

It might be because in this How to use Netflix on your Android phone or tablet
support page it doesn’t mention Fairphone or the Qualcomm QCM6490.

I already tried Netflix support, but they were very unhelpful and said I should try Fairphone support.

Maybe somebody else also has te same problem or a solution. I have put in a support request with Fairphone. But I think Netflix has te verify the phone or processor to make it work…

6 Likes

The same…only SD possible…

1 Like

On my FP5 it’s same.
I agree that missing Netflix support for Qualcomm QCM6490 should be the reason.

2 Likes

I can’t confirm this. Netflix looks perfectly sharp on my FP5. I don’t know where I can see which resolution it actually is, but even movie end credits are readable and don’t seem fuzzy. Are your sure that you don’t have any mobile data savers activated in Netflix’s settings?

I dont read that someone stated it isnt sharp? The setting is def saying this

I have the same in Netflix>My Netflix>Hamburger menu (top right)>App Settings>Playback Specification

It there says SD, Standard definition wich should be 480p. But as netflix doesn’t really care about resolution and it is all about bitrate (because data costs money) they probably have dynamic resolution depending on the scene, and maybe even depending on how busy their servers near you are. That might explain why sometimes it is way more noticeable than other times. But those are just guesses. It does say L3 so the quality will be less because the drm privileges aren’t good enough for their app.

But in DRM info it says the phone has L1. So Netflix has some other checks before you can have the better quality.

Okay, I found the specifications and it says SD on my FP5, too. But as I said: The picture is just perfectly crisp on the phone screen. So, why bother?

On FP4, it shows L1 Widevine even in Netflix app. Just to confirm it’s not a problem of FPOS in general.

In FP4 ist Max Resolution Füll HD in my FP5 IT IS also only SD, lets wait for the next Netflix Update, maybe WE could Set IT as Feedback at Google Playstore

Don’t know if it’s helpful, since I have a FP4.
But here on Reddit they solved by clearing cache and app data, then log in again.
https://www.reddit.com/r/oneplus/comments/kzojbc/widevine_is_l1_but_netflix_app_says_its_l3/

It was for OnePlus devices, but you could give it a try.

Just tried, and previously already reinstalled. But unfortunately didn’t work… Thanks for te suggestion

Solved with this update, however for me only after deinstalling and reinstalling the App

4 Likes

Just tried worked for me as well! Clearing cache and storage worked as well.

3 Likes