Fairphone 4 does not start at all

Suddenly, my Fairphone seems to be “dead” without an obvious reason.
Just had the phone in my frontpocket, maybe for one or two hours. Battery charge should be sth around 50%. When I got it to check EURO2024 results, it was completely off. Tried to turn on by pressing power button - no success at all. No vibration, black screen.

Tried the following without any other result:

  • push power button for around 30 sec
  • removed battery for ca. 20 min
  • removed SIM & SD
  • plugged into 3 different chargers / power supply with various cable
  • connectected to computer

Any hints what can I do now?
Thank you!

zabiwa

Did you let it charge some time (at least 30 Minutes, better longer) without trying to turn it on? In case something drained the battery it needs some time to charge…

Else check the Angels Map and see if an Angel is close who has a FP4 to test fairphoneangels

Yes, I’ve let it charge over the last night without any success.

So I guess it can be the battery, core module, bottom module. As you should have warranty def contact Fairohone support, else as said you can check the angels map.

Yes, I will contact the support since no Angel is close to my location. Thank you!

Update: Support adviced to send in for a repair. The repair center did a motherboard exchange, now it starts normally (but have other problems, see: Fairphone 4 5G reboots randomly after the latest system update)