Fairphone 4 5G reboots randomly after the latest system update

After upgrading to the latest Fairphone OS (Android 13, security update 2024-05-05, build number FP4.TP2G.C.0119.20240509), my phone started rebooting randomly. I’m also running Magisk 27.0.

Sometimes it happens while the phone is completely idle, sometimes while I’m actively using the phone. When using the phone it manifests as the system UI freezing for a few seconds (trying to open the app switcher gesture does nothing, notification shade doesn’t react to opening either), and the phone then reverting to the bootloader warnings about unlocked bootloaders.

I have 5G disabled. It happens while the phone is laying idle on my desk. There should be plenty of battery remaining (60%+ after a while of this). I have disabled Bluetooth, Wi-Fi, and NFC to no avail.

I haven’t manually changed anything else than the system update in between, but obviously can’t exclude Play doing whatever it feels like in the meantime.

Tried clearing cache (adb shell pm trim-caches 256G), no difference. Interestingly, the reboot seemed to happen after just about an hour of uptime.

Safe mode has been stable for 87 mins, so I’m going to call that a pass, but it’s obviously not super useful to anyone in that state.

Trying with no SIM next, since I don’t own a backup SIM to try with.

Please read here

It seems to have been a SIM issue, actually. I tried replacing the SIM with an eSIM from the same cell provider, and it has now been stable overnight!

I confirm the problem exactly as described. I would not marked it solved, because changing the SIM is not a solution, and having been stable overnight doesn’t mean the problem has gone

Before the update there have been no problems of this sort, so I think something in the update should be the cause

1 Like

If it was solved for the OP they can surely mark it solved and your issue might be a different one, so is your phone also rooted? If so check the link I shared and see if other solutions were found. So far thats only an issue happening to rooted phones and in this case FP will not help you to troubleshoot.

I agree that it isn’t the most satisfying solution, but:

  1. In the modern age of eSIM it’s at least workable, even if a bit annoying.
  2. It has now been stable ever since switching to eSIM. I haven’t had a single crash since, and it’s currently sitting at 38h of uptime. It’s always hard to prove a negative, but to me that’s a stark enough difference that I’m happy to call it sorted out.
1 Like

This can’t be the solution, at least not in general. I use an eSIM and I have the same problem, I guess. My phone just reboots like 15 seconds after unlocking the screen.

I actually have the same issue with random reboots. Although it is not a solution, more a workaround, I will try to switch to an eSim.

Replacing SIM with eSIM did not solve that problem - I already had 3 reboots since.