Fairphone 4 bootloop, without software modification? Weird issue, help needed

I received my Fairphone 4 few hours ago. I booted into OEM android and played around with it to see if it works. There were no issues that I have seen. Then I popped into the boot menu to see what is in it and selected “FPFB” or something of that name. I cannot remember because there is no documentation that i found. I assumed it is just a bootloader of some sort or a fast boot from the name. Device now is stuck on the loading animation. It does not progress. I attempted to boot back into the menu, but no matter in what way I boot my phone, it always goes back into the loading stage. Any idea on why it just got stuck in this, and it doesn’t do anything? ADB does not detect the device but when connected, it seems to boot on its own.

Sounds like you got stuck in Factory Boot Mode (FFBM). Hold Power Off until it turns off, then immediately press and hold Volume Down. That should bring you back to fastboot mode.
Just tried it myself, stressful few moments, but it worked :smiley:

7 Likes

How exactly do you leave it? Because I definitely entered FFBM but when I power it down and immediately press volume down nothing happens. And when I turn it on and hold volume down it keeps bootlooping.

Alternatively, you can turn off your Fairphone, then press the power button and volume down button at the same time until the device vibrates. After some seconds, you’ll see the fastboot mode

That’s from the official FP homepage

Where did you even find that? The only related result I get when searching for this is this thread. And it sadly doesn’t work, when I hold both buttons the phone just keeps rebooting and doesn’t vibrate once. It only vibrates when I release the buttons and then it keeps bootloading.

So you turned it off (take out battery if not possible) and then you pressed both buttons?

Its from the manage the bootloader Tutorial ,however this was written for FP3 and even if FP somehow added FP4 in the first section, the button combination might be different (I’m not that confident they really rewamped the tutorial for FP4, as also the command to unlock the bootloader is not correct for the FP4)

Yeah, I can turn it off without any problem but when I keep holding the buttons it constantly reboots to the “your bootload is unlocked” screen. Problem is the phone will only vibrate after leaving that screen so it’s impossible this way. Guess I’ll have to write support

Are you sure you are in FFBM mode? :thinking:
I just entered FFBM myself, you should see the bootanimation (those four blue dots dancing in a circle) basically non stop. Hold Volume Down + Power Off and as soon as the screen turns black release Power Off and keep holding Volume Down. That should bring you right back to fastboot (just tried).
Maybe that works better for you, I just find it easier to hit Volume Down immediately when the screen turns black, to each their own I guess :smiley:

Yeah, I definitely entered FFBM (I rebooted to bootloader instead of fastboot using adb and thought that FFBM meant fastboot). The phone does stay in the boot animation. I just tried what you wrote but it didn’t work. What I’m confused about is I don’t get what’s supposed to happen. Like when I turn off the phone (either with the power button or with the power and vol down buttons) and then just press the vol down button nothing happens. The phone doesn’t turn on again unless I press the power button and it doesn’t matter if I keep or don’t keep pressing the vol button because it just enters the boot animation again.

Edit: So my steps are:

  1. Watch boot animation
  2. Press and hold power and vol down buttons
  3. Release and press only vol down button when the phone turns off
  4. Now nothing happens
  5. If I press the power button the phone turns back on. It still gets stuck in the boot animation

Interesting :thinking:
If you don’t manage to get out of FFBM you will always be brought back to that mode.
:man_facepalming: I’m an idiot, my phone is always connected to my PC when I tinker with it and I just checked, leaving FFBM only works if it’s connected via USB, strange.
Could you please try again with your phone connected to power or a PC :pray:

BTW: Your first error wasn’t a error, you are supposed to adb reboot bootloader that brings you to what most people refer to as fastboot, adb reboot fastboot will bring you to fastboot in userspace, you will probably never need that.

6 Likes

Could you please try again with your phone connected to power or a PC

This did the trick, thanks for your help!

3 Likes

Hello,

when I boot on my fairphone 4, I’ve four blue dots who round around. I think i’m on bootloop. :frowning: I think the device has entered in boot to ffbm mode.

Is there a way to come back to normal boot ? I try recovery mode but it is the same.

Please can you help me ? Thanks.

Do you have some more information?

  • Were you trying to flash a different ROM?
    • If so, which?
  • Is your bootloader unlocked?
    • Did it happen directly after unlocking your bootloader?
  • Did it just happen out of the blue?

thanks for your reply.

  1. No, I don’t flash the device.
  2. The bootloader is locked. I tried to unclock oem but it didn’t work.
  3. When I reboot to bootloader, I think i press the volume key by mistake and it goes to boot in ffbm mode. Then, i’ve got bootloop. I tried recovery mode, start, and restart bootloader and it is the same thing (blue dots).

Is there a way to restore to factory ?

I’ve moved your posts to this existing topic.

Please try connecting your phone via USB to a PC (maybe charger only works as well) and then use the following button combination:

1 Like

Thanks to help me. I can’t do anything with my phone for now.

Ok, and when I’m in fastboot, what should I do to recover the system ?

Here is what I tried for now : Power off the Fairphone 4, hold the volume down button. I’ve got the bootloader screen on the phone. I can chose Recovery mode, Start, Boot to FFBM, Power off, … I tried the recovery and start mode but each time I’ve got the boot animation with the blue dots but nothing else displayed. So, I don’t know what to do. For information, device state says locking.

Then you probably aren’t stuck in FFBM mode.

You get the boot animation if you select recovery? :thinking:
That shouldn’t be happening, are you selecting the option with a short press of the Power button?

Two things I would try:

  • Select START and press Vol. Down as soon as you see the blue dots to start in Safe mode
  • Hold Vol. Up + Power until the screen turns black, then release Power and keep holding Vol. Up for another way to get into Recovery
1 Like

Hello,

well, I found the way to have the screen menu with the ‘Wipe data/factory reset’ option. So, I did a factory reset. After that I recovered my system. :slight_smile:
I’m happy. Thanks for your help.

I will create a new post because I’ve got another issue.

4 Likes