FP4 won't go into recovery mode

I was just browsing and all of a sudden my FP4 turned off and was stuck in a boot loop on the FAIRPHONE logo. I got into the boot loader with volume down + USB C cable, but when I select recovery mode it just keeps boot looping…it won’t enter recovery mode.
I didn’t install any other OS or did anything with the FP4, it’s all stock… How can I recover my FP4?

Does this work for you?


Tried everything in that topic. Nothing works…

Are you able to access recovery with fastboot reboot recovery or if that fails does fastbootd (fastboot reboot fastboot) still work? :thinking:

If you haven’t used fastboot before here is a tutorial how to set it up:

I can’t get the Fairphone and Android logo to “stay”, it always continues to loop…
The only thing I can do is go into the boot menu when I turn on the FP holding volume down and releasing it as soon as I see the FP logo. The first line I see is “FastBoot Mode” in red, so is this the FastBoot menu or something else? Maybe i’m stuck in fastboot mode?? When I plug in the cable when on the boot menu screen nothing happens and the “fastboot devices” command returns nothing.

Yes that’s fastboot, exactly where you want to be :+1:

If your phone doesn’t get recognized try a different USB port or cable, fastboot can be a bit picky when it comes to cables.

Tried 4 diffirent cables on 2 diffirent computers…no results at all.
“fastboot devices” gives nothing and “fastboot reboot recovery” just says “Waiting for devices” forever. Seems like my FP can’t connect to the pc.

If it doesn’t show up under fastboot devices it’s either not recognized by your PC (driver or USB issue) or you are lacking the necessary permissions. What operating system are you using?

For Windows follow the steps under Prerequisites here:

If you are on Linux, check if it shows up under lsusb and try using sudo fastboot devices.

In any case you might want to #contactsupport as well (if you haven’t already), they can be a bit slow to respond, better to get started early.

1 Like

Is in Settings, System, Advanced, Developer options USB Debugging enabled (green)?

In case you get in the process an Android robot lying on its back showing No command then read the article factory reset and recovery mode .

too true.

too late for that seemingly, Thaleb can’t get it to boot.

At least it’s under guarantee. Sounds to me like it’ll have to go back for repair (as anticipated by hirnsushi’s enjoinder to contact support). Could be a hw pb on the motherboard, memory or something.

1 Like

Yeah, I suspect that might be it, we’ve had similar cases before :see_no_evil:

But I’m not giving up hope yet, there’s still plenty of time for debugging before FP support reacts :smirk:


Nothing… I even installed the universial adb drivers just in case.
I also just contacted support.

I must say that I’m a bit disappointed that i’m already having a (hardware) issue in just 2 months time after purchase. I didn’t even tinker with it…


I can sing you a song about that :face_with_raised_eyebrow:

Please here long, but in the back of the line . . . :wink:

Alright, so you are on Windows then.

Did you try installing the driver mentioned in the instructions:

If Fairphone 4 does not connect, try installing the latest Google USB driver (ZIP) (click on the link and select “Save link as…” and click the “SAVE” button). To read the instructions, you can click here

If it isn’t a driver issue it’s probably still the USB connection. fastboot is notoriously difficult with USB cables, it’s a known problem (and not exclusive to Fairphones). I for example have to change the USB port if I’ve used the hold Vol. Down and plug in USB cable method before.

All I can tell you is keep trying different cables (especially from different manufacturers) and different ports (USB 2.0 ports seem to work more reliably, but that’s only backed up by my anecdotal evidence…) until one combination hopefully works.


Also tried connecting the Fairphone on 2 Linux devices and multiple different cables. lsusb and dmesg had no output…
This is probably a hardware issue. I’m gonna let support handle it.
Thanks for the help tho! :slight_smile:

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.