Fairphone 3 takes a long time to react after standby (up to 5 seconds until screen turns on)


I received my FP3 last weekend and there is one thing that kind of annoys me:

When I press the “on” button (the one below the volume buttons) while the phone is in standby it often takes up to 5 seconds before the screen actually turns on.

I’m not used to this kind of behaivor from my previous android phones. Is there something I can do to fix this?

I tried searching the forum for similar issues but I could not find any, maybe my search keywords where bad…

Thanks a lot in advance!

1 Like

Can’t confirm, works immediately for me.

A support contact form for the Fairphone 3 can currently be found here (just choose Fairphone 3 as your model) …


Sounds like an issue for the Support. Mine comes up instantaneously both via Power button and Fingerprint sensor.

@jarrad, has anything changed with the behaviour of your phone, or does the problem still occur? Have you contacted support and possibly got a response from them already?

I’ve been experiencing a similar behaviour (unresponsive phone in standby, duration up to 20-30 seconds) since about two weeks ago, but it happens sporadically only.

There’s also another thread describing such an issue: Switch on my FP3 takes too much time

Had the same problem.
Tried to deinstall Apps. First one worked: i deinstalled
Amazon Kindle
and afterwards everything works perfect again.

Edit: didn’t help fully. From time to time it reacts instantly, sometimes there is a lack of a few seconds…



The issue still occurs, also only sporadically.

The support isn’t really helpful, they want me to return the phone and to reset all my data which I’m not going to do for just an annoyance.

I’m fairly certain it’s a software issue (the button press is always registered by the phone but the respone, turning on the screen, is delayed).


I don’t have the amazon kindle app installed. I have amazon prime video installed though. I will try removing it.

I get your reasoning about the issue.
But support are suggesting a path forward, and you decide not to take it, and support isn’t really helpful? Good going :+1: .

Software issues are not always about logic and reason. Software development is a mess which makes early prototypes into market-ready products by declaring them as such and later rather puts multiple layers of plaster on cracks in the foundations (software developers will rightfully argue that mostly not software developers will do this, but marketing departments and decision makers).
It’s not an industry producing predictable results based on sound principles and techniques. The principles and techniques are there, but they are not followed and used to ultimately meaningful effect, because there’s no reason to. The quick-and-dirty approach saves time and money, the products sell nonetheless and nobody’s getting held accountable for conceptual inadequacy, so the system is broken and will not get better any time soon.
Just my two cents.

Long story short: There can be unpredictable, erratic and plain illogical behaviour in software, even more probably so in a conglomerate of multiple complex components forming an OS.
You will not get far operating on the requirement that it all has to make sense :wink: .

If no App immediately turns out to be the culprit, a factory reset will be a sound way forward.


I’m a software developer myself for more than 12 years. I’ve done embedded software as well so I’m aware of those things.

A software reset might help me (but also cause a lot of work to restore all the settings etc) but it would not help fairphone to find the actual cause of the problem which more people seem to have.

It’s typical first level support like “try turning it on or off”. I would prefer to have the actual bug solved, not a workaround that causes me a lot of work.

So I’m not going to bother with the support any more unless I have a hardware issue. Maybe when they have a large enough amount of customer complaints they will actually investigate and fix the bug.

I can live with the issue, it’s just an annoyance. Until then I just hope that either I myself or someone here on the forum stumbles upon a solution or that fairphone comes up with a software update that fixes the issue.


Hi everyone.

Same issue, stuck for a long time before unlocked (5/10s).
No solution found yet.

1 Like

I also sporadically noticed a similar issue when pressing the button to send the phone to standby:

  1. I play a video on YouTube
  2. While the video is still running, I press the power button
  3. The screen goes dark but I still hear sound from the video for about 5 seconds.

This problem has now disappeard after the next-to-last update :sweat_smile:

1 Like

Hej, I’ve been getting the same problem for some month now.
It was at start not too painful, from 1 to 2 seconds to open up and it didn’t occur all the time. Recently it’s been getting worse to the point that i needed to wait up to 10seconds to light the screen up, and if the phone was fully turned off, it once took almost 1 HOUR to turn on… I’m not exagering the number.

BUT, I’ve manage (I think) to fix it. I’ve tried to press the screen at the junction where the screen is linked to the rest of the phone and it seriously just magicaly turned on.
So after screwing at full capacity every screws of the phone, it works as it did before. Not a second of waiting time.

So if anyone is having this problem today, feel free to try. Tho I don’t know how good it is to screw that hard the screws in the phone. Maybe it has to be like that, maybe not, but it worked for me.


Hi Mrister_Yo and welcome to the forum.

Glad to see you have resolved this issue.

However apart from the aforementioned factory reset, which is a last resort before sending a phone to ‘support’ there is an option to start in safe mode rather than a factory reset. This keeps all personal data and app data from the default apps.

1 Like

question to everyone who had this issue: did you have an SD card installed?
I’m having the same issue, and just found an FP2 issue that was solved by removing the SD card. I did that and for the last 10 minutes it didn’t show this issue yet. now I’m wondering whether all this delay issues might be caused by broken/misconfigured SD cards… or whether some users had this issue without an SD card installed, so my theory is proven wrong.

btw, it has to be a driver/firmware issue or a mainboard malfunction in my case:

  • installing a custom rom (/e/ in my case) didn’t help.
  • and when switching the mainboard from my FP3 to my sister’s FP3 , the issue goes with it. (I always also switched the sd card)

If an SD card is formatted as internal it is treated like the main memory. Then if a required app on start up is on the SD it will be a bit slower to respond et.c

Well, you are only partially right. Yes, this could be one reason. But in my case it definitely isn’t, I never configured as internal.

And anyway, my question was not “why the sd card might have been the reason for start up delay”, but just “if they had one installed”.

For the next one who’s searching for help with delayed start: please report whether removing the sdcard (also) helped with your delay.