Fairphone 3 stuck in fastboot mode after latest update

Hi there,

wondering if anyone can help as customer service has been rubbish so far.

My partner and I got a FP3 at the same time, and with this latest update (I thankfully did not install) my partner’s phone got stuck in fastboot mode.

No matter what option we select (start, restart bootloader or recovery mode) it just returns back to fastboot screen.

We have done all the usual things to do in this kind of situation, turned the phone off and on again, plugged it into a laptop, taken the battery out, even turned it off and left it in a drawer for a week before turning back on again.

Nothing has worked.

When we contacted customer service they only suggested this usual “turn on and off” stuff, which we had already tried…very frustrating.

So this latest update has left my partner’s phone totally useless at the moment.

What can we do?

Thanks in advance for any useful suggestions

I would recommend AVOIDING the update on FP3 if you are considering and definitely BACK UP YOUR STUFF if you’re going to risk it!

Sorry to hear it and since I just opted for /e/ for the FP3 in our family, I unfortunately have no idea what could have gone wrong.
I am not so sure, if a general warning of the update is neccessary.

Annoying and frustrating as it is, things like that can always happen. (So a backup usually is a good idea (not that I would head my own advice all the time :wink: )).
I hope someone, who is more abled technically can help you out here.
There are some real :woman_mage: wizzards :mage: here in this forum.

According to another thread the latest update seems to have worked for other users without any problems, if it was this update:

I.e. the latest one in this wiki

Hi Naomi,

which update are you talking about - the A.0120 that has just been released? I have installed it yesterday without any issues.

Which release did your partner have installed before the update? Are you on stock Fairphone OS or have you made major modifications? What carrier do you use?

Best wishes,

The phone was updated on the 29th of April but didn’t pay too much attention to the “stock number” of the update.

No modifications made, on stock Fairphone OS. Unfortunately we don’t take note of the updates, just back up and let the phone do it’s thing each time.

Funny how everyone thinks it’s necessary to recommend a back up…we did that. There is no issue with the data on the device.

What we need, please, if anyone, without any recommendations for backing up or comments on how the update has worked for you, has any information or suggestions (NOT turn it off and on) on how we can GET THE PHONE WORKING AGAIN it would be gratefully received.

Thanks in advance

Whilst this may take you outside your comfort zone, have you come across this thread as is pertinent if you can access “fastboot mode”?


Have you tried a factory reset?
There is an option for “Fairphone 3 does not boot anymore

If this does not help.
Is there one of the great #fairphoneangels in your area.
Maybe you could get some help by phone or another way, keeping the social distancing of course.

Sorry, if I crossed you.
So, just to clarify my intentions:
As this forum is for everyone with troubles, threads will be checked by others wit the same troubles. Therefore I meant to express two opinions:

  • Your advice to backup is absolutely correct and should be followed
  • Your warning against the update is not (correct and to be followed)
    And that’s as well the reason, why it is a valid point to tell that the update went flawless for others; even though it really will not help you, unfortunately.
1 Like

Hi Naomi
I got exactly the same problem with my new Fairphone 3. Yesterday (15-05-2020) my F3 got stucked in Fastboot Mode after the firmware update. None of the options resulted in any other situation than a return to the Fastboot Mode. I also went through the suggested reset procedure, without success.
How did you proceed with your case?

Still no success HansX. I’ve contacted fairphone’s support team again, hopefully they can provide a more concrete solution this time :crossed_fingers: