English

Fairphone 3 softbricked with Usb drivers problems

Hello everyone,

I spent time on the forum but I didn’t find the way to fix my problems…
I’ve just got a FP3 on Android and tried to install e/os/. I followed the instructions of Fairphone and the /e/documentation. My laptop is on windows 7.
Since the beginning i had problems with usb drivers and adb didn’t detect the phone everytime. The usb cable work, brand new, charging and connecting the laptop to the phone, but adb didn’t find it. Bootloader unlocked, developper mode ok, OEM unlocking on, fastboot on. USB debugging on, USB pref on file transfer ok.

I finally suceed every step 'till the fastboot commands, had some error message, it couldn’t find the files .img . ADB no longer recognize the FP3, and same with Fastboot. I’m stucked into the fastboot mode on the FP3, and the Recovery mode ends in “no command”. Did I soft bricked the phone ? The Usb cable is charging.

I’ve tried Universal adb drivers, command adb kill-server and start-server, unistall and re-install adb, with no success.

I have no bill for my phone because i’ve got it from secondhand, so I don’t no if Fairphone will help me…
I’m French, sorry if my english sounds weird…

Thanks for taking the time to read me

Hoping someone could hep me, thanks in advance

Charles

Hi Charles,

I think the easiest would be to try the manual installation of the Fairphone OS, see here:https://support.fairphone.com/hc/en-us/articles/360043337512-Install-Fairphone-OS-on-Fairphone-3-using-a-computer

1 Like

No, this is the stock Android #dic:recoverymode (<- see link on how to navigate there).

Hi, and thanks for answering me.

I did exactly what you said and I can run adb and fastboot without prefixing them, but when I put ‘adb devices’ in the command it says ;
‘list of devices attached’ and nothing. Same with ‘fastboot devices’

The fairphone is charging but it does not appear in the computer file. The fairphone is in fastboot mode. In the manager of Windows (other devices), I can see ‘Android’ with a yellow warning panel and even with Google USB driver and Universal Adb driver, nothing . I can connect other smartphones to my pc easily, so, I don’t know… Maybe I can try it with another laptop and another usb-c cable.

If you can, it won’t harm.

1 Like

Hello everyone, using an other laptop and official fairphone usb cable I managed to install e/os. I’m just a rookie with open OS but we have to start somewhere ^^

Thanks for your advices

4 Likes