Fairphone 3 loses wifi connection

And likewise I respect you, your time and input, and fairphone too of course.

It could be a hardware problem indeed, I don’t know. But as I said, I’m not going to recommend FP anymore, I have in the past, and I’m very unlikely to stay with FP or buy another one of their products.

Add to that I can’t recycle with them, and the whole experience was a waste of time and money.

1 Like

Just to say I have the same issue. I hope it is a hardware issue.

On my FP3+ I also have the very similar problem that the phone disconnects from the wifi all the time (two or three times per hour). The difference: It always reconnects automatically after three seconds.

Which is a very bad thing for video calls, streaming, downloads, connections to Chromecast, wifi audio players, etc.

Finally I found a “solution” for this: If the 2.4-GHz access point is set to 802.11n-only, the wifi connection is stable.
But if the access point ist set to any mixed mode (for example: 802.11bgn or 802.11gn), then it continues to disconnect and reconnect all the time.

Of course, this is not a real solution, but a workaround. Maybe it helps you!

Let’s hope that Fairphone will fix this bug with an update very soon. Because I can not change the configuration of all access points I am connected to (public transport, at work, …).

I will try the 802.11n approach!

Additionally, to me it seems that the wifi connection instability is caused by Android 10. With Android 9, it did not happen, or at least, not so often that it for my attention. Does anybody else also have that impression?

Update: the router was already on 802.11n only. I have set it to bgn, plus enabled 5GHz (hmm why was this router still on 2.4?). No WiFi losing connection experienced since…

2 Likes

I have to admit that the “802.11n-approach” is not a real solution. It makes disconnects happens less, but still. I also found out, that using 40 MHz bandwith is more stable than 20 MHz, but still disconnects happen.

So, nothing is really helpful. I provided more detailed informations to the Fairphone support team and hope they can help.

1 Like

Hi Ontheair, I would be grateful if you could share any hint provided by the support team, I am struggling with WI-FI disconnections since day one…

Hello Ayn,

I am sorry, but I can not share any hints to solve the problem. I gave a lot of informations to the support team, including detailed descriptions of the problem and even comparisons between the FP3 and other smartphones running SSH-connections with screenshots (running on all smartphones, crashing / disconnecting only on the FP3), etc.

To make a long story short: The support gave me no hint to solve this problem. They said, they will forward my informations to the developers.
So I still have this unstable wifi since the first day, same like you and others.

Sadly, since I am using the FP3+, there was no single update with bug fixes. Just delayed Google security patches. No bug fixes since months - and the unstable wifi is just one bug out of many others.

We all have to wait if this and the other bugs will be fixed by an update :frowning:

Thank you so much, let’s hope it is not an hardware issue…

I guess it would be a good idea if you contact the support, too.

Yesterday I have browsed the router options and I am trying to connect the phone with the 2,4 Ghz frequency. So far no disconnections, I will wait few days and then contact the support, maybe the issue is only related to the 5 Ghz frequency?

1 Like

For me the problem exists with 2.4 GHz.

I found a “solution”. When keeping the display active all the time (there are apps for that), the wifi is stable, no disconnects anymore.

Of course this is not a practical solution. But it shows that it could be a wrong implementation of power saving instead of an hardware issue.

I am keeping my display active all thr time now when playing music from the phone to wifi receivers, using Chromecast, etc. Working great!
Problem is, of course: Battery needs to be charged much more often.

So, still waiting for an update and a bugfix…

4 Likes

Good finding! Indeed, it seems that the wifi connectivity issue only shows right after the screen activates. During operation, I cannot remember an instance of WiFi losing connection. This may be different for other users, but the relation to screen activity is at least suspicious!

2 Likes

One week without disconnections using the 2,4 Ghz band. I live in a house with thick walls and I have read the 5 Ghz suffers more in this situations. Maybe the phone struggles to reconnect when the connection is lost during the standby mode? (for example because the phone has been moved from a room to another without unlocking it)

Have you enabled “Keep Wi-Fi on during sleep”? Please check your Wi-Fi settings.

Hi DeepSea, of course I had the setting “Keep on WIFI during sleep” set to “always”. It is the default.

Unfortunately it is not possible to check this setting again because it just disappeared - same like the WIFI band switcher bug mentioned here.

miss

Finally I solved the issue with instable wifi, which was disconnecting and reconnecting several times per hour.

It looks like the FP3(+) is a bit picky with access points. Since I removed my older TP-Link access point and using a FritzBox 7590 instead, the reconnects are gone. There is now stable wifi on my FP3+.

And 5 GHz is working again too, after doing the workaround mentioned there.

5 Likes

I had this issue for months and tried all the advice from this thread to no avail. My phone was disconnecting from my wifi about every time I switched the screen off or used it more than 10 minutes. And it stopped connecting once that happened until I manually forced it to reconnect.

Yesterday I found out that there is a Reset Wi-Fi, Mobile and Bluetooth function in android (to find it search for “reset” in system settings.) I used it yesterday evening and have had a stable connection for the last 18 hours.

Just wanted to dump this here because it is the first thing I found on google whenever I was trying to find out a solution for my problem.

I’m on a FritzBox 7590 as well, WiFi is now again using same SSID for 5 and 2.4 GHz and I still seem to have a stable connection.

7 Likes

Thanks a lot. This did the trick. Actually on the freshly bought FP3 for my mom, this issue only appeared AFTER the android 10 update, so following the “reset WLAN” workaround really helped instantly. Regarding stability, that might still be an issue, so I will keep a watch on that before I hand it over. At least, reconnecting automatically dramatically decreases the required attention

Additional info:
Checked again, working fine.

What happened: after android 10 upgrade, the wifi settings became unstable. Noticeable, after sleep & reboot WiFi did NOT reconnect automatically to the known network.

Adittional symptom:
Under Settings → Network and Internet → Wi-Fi → Wi-Fi preferences → Turn on Wi-Fi automatically
Changing that setting did not work (tested by reboot after changing it off and on again)

FIX:
Set back/reset the network settings ( System → Advanced → Reset options → reset WiFi, Bluetooth and mobile settings). Thanks Paul121, @ontheair and @Simon1 (just changes your arrows and spacing here :wink:

For me WiFi worked directly after fixing, throughout reboots and after sleep.

No additional changes were nessessary on the FP3 to restore stable WiFi access.

Setting up the Wi-Fi connection again, rebooting (several times again) and observing over the day showed no regression, seems to be stable now.

(android build no. 8901.3.A.0107.20210503, current patch levels and updates applied on 2021-05-30)

3 Likes

I have this exact issue with my Fairphone 3+. It has happened the entire time I have owned it.

When connected to my home 5GHz network (Ubiquity Unify AC Pro, channel 36), my wifi connection will drop out for a period of 10-30 seconds every few minutes. The wifi symbol in the top bar will show a cross in it, and the phone will use mobile data for a brief period, then the cross will go away and the wifi connection will resume.

This only happens on my 5Ghz wifi (I have named my 5G and 2.4G networks separately so it does not auto-switch).

I cannot solve this problem by forcing the phone to use the 2.4G network, because I also experience this issue, which means I get a painfully slow 1-3Mbit/s connection speed (the wired connection speed is 30Mbit/s and the 5G network depending on signal gets about 25Mbit/s).

I tried resetting network settings via android settings as suggested by others in this thread, but the problem was immediately observed again.

I tried gathering some logs using ADB when the wifi dropped and couldn’t see much that looked relevant, however there was this:

06-30 12:10:03.727  1804  1804 I chatty  : uid=10082(com.android.systemui) identical 1 line
06-30 12:10:03.727  1804  1804 I StatusBarMobileView: lindaguo updateState activityIn =false, activityOut = false, state = MobileIconState(subId=1, strengthId=1283, roaming=false, typeId=2131231203, volteId=0, visible=true)
06-30 12:10:04.248   569  2675 W ServiceManager: Permission failure: android.permission.NETWORK_STACK from uid=1073 pid=1920
06-30 12:10:04.249   569  2675 I netd    : setProcSysNet(4, 2, "wlan0", "retrans_time_ms", "750") <1.43ms>
06-30 12:10:04.250   569  2675 W ServiceManager: Permission failure: android.permission.NETWORK_STACK from uid=1073 pid=1920
06-30 12:10:04.251   569  2675 I netd    : setProcSysNet(4, 2, "wlan0", "ucast_solicit", "5") <1.17ms>
06-30 12:10:04.252   569  2675 W ServiceManager: Permission failure: android.permission.NETWORK_STACK from uid=1073 pid=1920
06-30 12:10:04.253   569  2675 I netd    : setProcSysNet(6, 2, "wlan0", "retrans_time_ms", "750") <0.95ms>
06-30 12:10:04.254   569   569 W ServiceManager: Permission failure: android.permission.NETWORK_STACK from uid=1073 pid=1920
06-30 12:10:04.255   569   569 I netd    : setProcSysNet(6, 2, "wlan0", "ucast_solicit", "5") <1.29ms>

Hi @bengourley

I have only noticed this since the 0107 update ?? which came out 28th May.

A bit annoying as I use wifi calling on EE via FritzBox! 7530 on 5Ghz

Further if I try to connect manually it takes 24seconds, regularly other than the 3 seconds when wifi is initially enabled.