Fairphone 3 GPS questionable accuracy using [e/OS] maybe

I have a question about the accuracy of the Fairphone 3 GPS.
I have an app called Trackbook on the FP3, a Terracube 2e both running e/os and on a stock Lenovo tab 3 gen 3.
On the Terracube and lenovo my location is accurate to a few metres. On the FP3 it is off by about 120km. yes Km
Has anyone else this issue, or am I doing some thing wrong with the setup???
All 3 devices are sitting side by side.

https://community.e.foundation/search?q=gps%20fp3

Which /e/OS version is running on the Fairphone 3 and Teracube 2e (Terra Cubes are not phones :wink: .) respectively?
See here to get detailed info to be able to really compare … [HOWTO] Give complete /e/OS version info easily for support, answers, comparison etc - eOSWiki - /e/ community

Are the location settings in Settings - Advanced Privacy the same?

Fairphone 3 Build e_FP3-user 11 RQ3A.2110001.001 eng.root.20221129.182930 dev-keys
/e/os 1.6-20221129238947

Teracube 2e e_emerald-user 11 RQ3A.211001.001 eng.root 20221129.172113 dev-keys
/e/os 1.6-20221129238947

location settings in Settings Advanced Privacy are the same.
FP3 shows the phone about 100 km away

I’m running 1.6-s-20221201239247-dev-FP3 (s is Android 12). Location works totally fine for me.

Have you tried a real shutdown (no reboot) of the phone and turning it on again after a few seconds?

Users report in the /e/OS forum that interestingly with some location issues the HERE WeGo App wouldn’t show the issues when other Apps would. Perhaps worth a try, even if just to see whether this App can get something out of the GPS.
(I didn’t get yet why one App would behave better than the other when it’s the OS providing the location.)

Else (from a topic about a case of non-working location) …

Check that all is ok in Settings - System - microG - Self-Check, especially the location-related permissions in section “Permissions granted”.
Check that Settings - System - microG - Location modules - Mozilla Location Service is enabled (unless you disabled it deliberately).

Check that Settings - Location - Use location is enabled.
Check that Settings - Location - Location Services - Wi-Fi scanning is enabled (unless you disabled it deliberately).
Check that Settings - Location - App location permissions lists the Apps you want to use with location under Allowed (it’s “Allowed only while in use” for me) … else enable Settings - Apps - See all … apps - (the App in question) - Permissions - Location - Allow (probably “Allow only while using the app”).

Android 11
os is 16-r-20221129238947-stable-FP3
Did a shutdown, Not the phone in in the middle of a 4 lane highway 20km away. Getting closed to home.
Did a 2nd shut down now 123 km away according to OSM
Removed battery
No different 100+km off

Jeez, your precision is worse than without having GPS at all (relying solely on telephone masts and neighboring WiFi)!
Could be the GPS antenna is somehow disconnected (due to choc or disassembly)? Clearly your GPS is not working at all. Normally GPS chips are fairly standard and should have a standard error of meters, not kilometers! Standard error which should over some time get smaller as they (re)build their Assisted GNSS tables.
Has it ever worked/been accurate? If yes, did something change since?

May have found something. The FP3 GPS was accurate until I installed e/os using their Easy Installer.
Up until then the GPS was within a few Metres (in the house). I mostly use it there for a weather app, with climate change one never knows what to expect from the time I walk out the door to I get on the motorcycle it could change.
After the e/os installion I notice the inaccuracy in house. Today I tried it outdoors using Track Book, accuracy was within a few metres.
Could it be possible that that the e/os GPS software some how requires a stronger signal for the same accuracy?

Unless you are near enough to a window (to “see” GPS satellites), locating you indoors will rely on a database with known locations of Wi-Fi networks and cell towers (if there are any in range, and if the feature is not disabled).

Lacking Google’s database for this by default, /e/OS uses the Mozilla Location Service (mentioned above), thus results may differ.

But this shouldn’t locate you 100 + km away either, I guess.

1 Like

GPS reception ist not possible in house, but not so privacy aware Software can use other sources for orientation, Last known position, WiFi Access Point names, mobile connection.
It‘s possible that /e/ strictly use the phones GPS data and therefor can only navigate, when it really sees the satellites.

Hi CFA

not sure if this is helpful in your case but did you try to calibrate the compass (&GPS) on your /e/-OS ?

At least it´s worth a try cause it´s easy to do, doesn´t cost anything and also doesn´t mess up anything :wink:

I´ve faced location issues several times in the past on different devices and usually calibrating the compass fixed that issue for me within minutes

Best
DonFnord

1 Like

^ As @Incanus said.
Download one of the many free GPS test apps (I’ve been using GPS Test Plus for years. There is a free version.), and check what your phone’s GPS actually sees.

Try it in your usual environment (where you usually use it), and try it also outside, somewhere you have as good a view to the sky all around as possible. Just to make sure.

At least that’s not the default in /e/OS.

Did you use your WiFi elsewhere recently? … I’ve seen this happen on DTRH festival in Beuningen, Holland. My phone positioned me at the Lowlands Paradise location which is about 60 km imprecise … both are Mojo festivals …

If I am outside the GPS accuracy the FairPhone 3+ is within a few meters. When I am in doors the GPS shows me about 180 KM as the crow flies away from where I am. Our household has 5 other devices with GPS, when they are side by side in the house all but one have an accuracy of less than 10 metres, the exception my 10 years old TomTom GPS. This whole accuracy issue started after I installed e/OS. Not sure if the problem lies with the e/OS interface to the GPS sensor or what.
Hope this is clear enough

@CFA Did you read the above

So maybe check out the MLS

https://location.services.mozilla.com/

and contact e/OS

Also, MLS might just correct itself after your device catches some wifi signals and associates it with a GPS fix. Stroll around in the neighbourhood just a bit more :wink:

Google pb for now has more coverage and brainbot power and is still being fed by all your other devices (edit) except for TomTom.

Cheers

maybe try the App GPS Test where you have some options to relaod “assist data” etc

read above.
One of the devices that it tried is a TerraCube 2e running e/OS. It’s GPS is off by a few metres and the FP3 is off by a few 100kms. :confused:
I send a question to the e/OS forum maybe they have a solution

1 Like

Not familiar with the term assist data.

I assume you can do some search and reading to get further information.