Fairphone 2 Ubuntu Touch

we are working on it.

Working:
We can register a SIM card to the gsm-network
We can send and receive a text message.
We can read the IMEI
We can make and receive a call with commandline AT commands WITHOUTaudio

Still not working :
No voice call - GUI does not respond yet
No voice call -No audio
No data connection

If there is anyone who has experience with AudioflingerGlue, Please join our telegram group. https://telegram.me/joinchat/AI_ukwlaB6KCsteHcXD0jw

8 Likes

I have updated the build guide (post 2)
Added
<project path="vendor/fairphone" name="proprietary_vendor_fairphone" remote="smoose"/>

3 Likes

Hi everyone, and about A-GPS? Or is a _thin_g that only works in commercial Ubuntu phones?

3 Likes

Hey, A-Gps on Ubuntu Touch is currently only available through Nokia HERE on the commercial devices. But we’re trying to figure out, if it is possible to use HERE on the FP2 or preferably on all the UBports devices without paying a ridiculous royalty fee. We will let you know how it goes. :slight_smile:

There are plans to implement the Mozilla Location Service some time in the future. A bounty on bountysource has been set up for this. So if you’re interested in dropping a few bucks to the cause, check it out: https://www.bountysource.com/issues/39808752-support-for-mozilla-location-service-a-gps

6 Likes

Sounds good, @NeoTheThird

1 Like

Hi

I’m still trying to boot to fastboot, but FP2 stays in loop when holding volume down + power button. If I release the buttons the phone stays with the logo FP2 powered by android.

I’ve tried also with adb reboot bootloader, but nothing happens. ADB is working fine with my other devices, FP2 is not recognizable.

Any tips? :slight_smile:

1 Like

If I release the buttons the phone stays with the logo FP2 powered by android.

This is in fact fastboot mode. :blush:Try fastboot devices.

3 Likes

Thank you Stefan!

Sorry for the “spam” :slight_smile:

2 Likes

Time for a little update on the A-GPS thing: Sadly, Nokia HERE will not be added to the UT community ports. :frowning:

But no need feeling down, we still have the option to implement Mozilla Location Service! Again, if you want this and you want it now, you could add some zeros to the number displayed at Bountysource.

We’re currently talking to Alan Pope (Community Manager at Canonical, awesome lad) and if we’re lucky we will get some smart canonical devs working on that! But we’ll see that after the holidays…

Btw, we now have our very own shiny new Fairphone-subsection in the UBports forum, so if you want to blab about Fairphone and Ubuntu Touch, you know what to do!

Have a good one everyone! :slight_smile:

6 Likes

Wow, great news that Canonical appreciates your work! :smiley:

As for the subforum: I was visiting the ubports forum just some days ago and was wondering why there is no specific section for the Fairphone… :smirk:

1 Like

@Stefan
We are on it now : )

Ubports forum is ready to handle topics related to porting FP2 to Ubuntu touch.

2 Likes

And here is handy link https://forums.ubports.com/category/29/fairphone-2

1 Like

Hey all,

I’m a proud new owner of a FP2, and reading up on threads in here, as wel as on the ubports forum and even discovering https://ut4fp.org/ (that’s you guys also, right?), I’m amazed and excited about all the progress!

I got UT installed as per the guide on https://ut4fp.org/page/getting-started, and am running your pre-alpha system.img.

I’m no programmer, but certainly a tinkerer willing to dig a little deeper and learn new things, and am not afraid of a terminal. if there’s anything i can do to help you along (and my self too, as soon as gsm works, i’m switching full to my UTFP2 :wink: ), like run tests and fetch logs, please let me know. If money helps, i may even have some of that too :wink:

for now i can see

  • it recognizes gps is on, but as of yet am not getting a location fix (tested with scopes, SensorsStatus and uNav)
  • it detects a SIM card in slot 1, not in slot 2 (do i need 2 SIM cards inserted for it to detect slot 2?) but doesn’t ask for the SIM PIN at start up, doesn’t allow me to activate the SIM at a later point, and doesn’t retrieve provider/carrier info. there is a section in system settings>privacy&security about SIM PIN, but i’m not sure if and what to do there?
    -connecting external display works up to when [MSDisplayAdapter_24] says it’s connecting, and then Unity8 crashes. (this bit is outside of your scope of interest i guess)

greets,
Hugo

2 Likes

Hi Ubuntu Touch gang! I’d like to draw your attention to this topic: :slight_smile:

It would be great to see your work at the next European Fairphoners Community Trip to Amsterdam in 2017. If you can make it, please post in that topic. :slight_smile:

2 Likes

News from M. Gripsgard: "Great news here, so just got voice call working on Fairphone 2 today…"

7 Likes

oh and btw, quite new, just some impressions of UB on FP2:

5 Likes

Thanks for the video, it looks promising!
Did you shoot it with another Fairphone? It looks like there is a problem with the focus, as reported on several Fairphones (including mine):

1 Like

I did not make the video… and I do not own a FP.

2 Likes

Ok @sverris!
Just a thought: I watched the video on Youtube and in the comments, the person who posted the video wrote

“there is a bug that drains the battery pretty fast, waiting for new images”

I wonder if it is a bug related to the Modem files and if installing the old Modem Files would help, as it does with Sailfish OS. See @explit’s explanation:
https://forum.fairphone.com/t/use-of-proximity-sensor-drains-the-battery/22155/31?u=chrisse&source_topic_id=23475

On the Sailfish Wiki, there is also a description of the workaround:
https://wiki.merproject.org/wiki/Adaptations/libhybris/Install_SailfishOS_for_fp2

I don’t know if it helps, but I hope that Ubuntu will soon be available on Fairphone!

3 Likes

This would a question for @wouterx

2 Likes