Fairphone 2 Open OS is available

Hello. I tried using the "Method 1: Using the OTA package"
I downloaded the latest version onto my phone. Then went to Amaze file manager. Tapping the file to start the installation procedure only opened the zip and then the folder.
Fairphone Updater did not process the file or ask me to restart my phone to complete the installation. Any ideas?

Did you perhaps at any point get the option to open the file with Fairphone updater or Amaze and you chose Amaze?

Ah yes. Now it seems if, within Amaze, I long hold/right click the zipped folder, I can now choose Updater from among the applications to open it with. Brilliant. I’ll continue along that path! Thanks.


Hi all,
I updated from the FPOSOS beta and I had to do the same trick I used to flash the beta, in order to flash it (I had to flash from TWRP the fp2-sibon-16.04.0-ota_from_gms-userdebug ZIP, not the flashable image one).
Also I still suffer of unexpected reboots (I updated yesterday morning and 1 hour ago I had a reboot while unlocking the screen…) and the weird screen scrolling. Didn’t notice yet if there are also ghost touches.
P.S. also updating from the beta erased all user data!
Bye! :slight_smile:

Hi again,
I am not able to choose the external sd card as storage location for backups in Titanium Backup…I allowed writing permission through amaze and I can add folders on the sd card through amaze. However through the settings in Titanium Backup, when I navigate to the sd card as back up location, I can not choose it…Somehwere above, it says this folder is not writable or something (schreibgeschützt). What am I doing wrong? Thanks again.

Look here SD Card no writing permission in FP2

In order to use the SD card to store the backups (if you don’t want to mess with the system file to enable writing on it) you can use the following folder path: /storage/sdcard1/Android/data.
This is the only location where (in their standard behavior) apps are allowed to write on external storage, starting from Android 4.4.4.
Inside this folder there should be a folder named like the full package name, for TB is “com.keramidas.TitaniumBackup” but beware: if you uninstall TB (the same happens for every other app) all the files in this folder will be also removed by the uninstaller so be careful when you use this folder to store apps data on SDCard.
Bye! :slight_smile:

1 Like

I’ve never managed to get Racoon to work. Shame, I liked the concept. If you have any tips please let me know…

Well, I had no problems but I can describe how I did it.
So: I downloaded the .exe and executed it. It was not a proper programme to install but rather a code which you have to run each time. When it opens you have to log in with a Google account and afterwards you can use the search for finding the apps you need. You can click on the app names to get more info. Click on download to download the app. At the flag “transfers” you can see your downloads. Just open the folder link and copy the .apk to your phone and install it.
At which point it didn’t work?


What are peoples thoughts on this so far? I will probably make the switch if it is stable enough. I am sick of Google and don’t use many apps. In terms of stability what is the verdict so far? I have seen a few issues here. Are those widespread? Also, childish as this sounds, is the lock screen the same? Damn, I love those widgets.

FPOSOS works for me as stable as the stock OS, so it runs absolutely fine and stable!


I can confirm that.
Have an uptime of 191 hrs.
Great Job!:ok_hand:

The lock screen info “you fairphone for” still does not get the correct information. Looks like a SELinux issue:

Inode 2 is the persist directory, and FairphoneClockData complains with EACCESS…

1 Like

Thanks. I gave up on it some time ago but I remember running the program, entering a Google ID and password, select the ‘create new’ option, and then it says ‘Login, please wait’ - for ever…

Hmm, I never experienced that bug… Maybe you should try making an account at Google’s website…


Works great… I am very happy with it…

Things I noticed after 2 weeks of usage Fairphone Open OS (16.04.0):

  • Time is lost after every reboot
  • Some random reboots (may be the time issue)
  • “Your fairphone for…” has wrong date.
  • Phone freeze over night (wlan & mobile data is off)
  • Screen flickering only after reboot for about 1 minute
  • If the phone was already encrypted, I had to do some instructions to get it encrypted again.

It’s a very good release, but please fix that time issue. I can’t use my FP2 as an alarm clock at the moment. I don’t trust. :wink:

I’m only for two days on FP Open OS 16.04… My Wifi drops the connection from time to time, no regularity discernible. It’s the same setting as before (always on and so on), and other devices on that SSID show now problems. From logcat I can see a cumulation of

after some of those messages the WLAN connection gets dropped.

Also, I noticed the following line in logcat:

Anyone else has the same effect with WLAN on FP Open OS 16.04?

I was hoping to be able to backup my phone to the SD card from the bootloader, but it complains about not being able to mount the data partition (which is encrypted). Is there any way to simply backup the partitions, without having to mount them? I’d actually prefer the data to remain encrypted.

Otherwise this release has been working very well!

Thanks. Creating another Google account to run Raccoon worked on one computer. But when I tried to use it with Raccoon on a different PC I have the same isssue again.