English

Fairphone 2 Open OS is available

That’s really great news. You saved my weekend.
Thank you Fairphone crew,
I’ll have a beer on you!!!

3 Likes

You need to disable signature verification somewhere in TWRP.

3 Likes

Nice. I haven’t looked into this, but thank you for all your hard work.

2 Likes

Thanks, now I don’t get the error and TWRP says “Success” but after a reboot there is still no XPosed Installer on my phone. Tried it twice to make sure…

Installing the Xposed framework zip in recovery is the first step, after that you install the Xposed installer apk in Android.

3 Likes

@rick: Nice! Thanks a lot for your great work! :thumbsup:
Some comments/questions on this:

  1. Have all the changes been included into the downloadable Gerrit code for compiling? I.e. is this code up to date with (the bug fixes of) the FPOS 1.2.8 version? I don’t see much changes in Gerrit code review, but I’m also not that familiar with Gerrit, so I might just have overlooked it …
    I guess that TWRP and root access are not included in the code, as everyone might add this by themselves if they like to?!

  2. I’d be interested in how you incorporated root access?! Have you essentially followed @Max_S’s path of building a boot image including a su binary or did you take a (totally) different approach?

  3. I’d really like to see support for Unified Nlp in the FPOSOS as well, and from your description it seems that you’re already working on it. Just to play safe: You are aware of @jochensp’s patches to make Unified Nlp working, aren’t you? :wink:
    By the way,

There are problems acquiring your geo-location on the device

sounds a bit harsh, given the fact that GPS should work flawlessly and quite accurate, I guess. At least, it does so on my self compiled version.

(@All: Sometimes the forum software sucks. I wasn’t able to get the last two sentences indented. Now it looks as if this paragraph doesn’t belong to the third point - but it should! Any idea how to do this? If I delete the blank line before it, it gets merged into the quote, which is also not what I want. These types of bugs are what I sometimes hate the HTML and WYSIWYG editors for. :rage:)

1 Like

how do i install openGapps? i have been trying to do it for the last 30 mins…without any luck…i ve downloaded the FPOSOS, then downloaded a browser through F-Droid, opened opengapps.org through the browser and then downloaded the pico version of 5.1 ARM64. Tried installing it through updater. The FP started new in TWRP mode. I then do not know what I did, but I did not manage to install open apps. :frowning: Help!!!

I don’t have FROGS ( :slight_smile: ) yet, but did you try to reboot in recovery and from TWRP choose “install zip” then find your picoGAPPS and apply?

The snapdragon 801 is a 32bit CPU. Have you tried installing the 32bit version?

Thanks NicoM and ungutknut. I just realized that and installed the correct file…voila!!!google play store is installed. however, i get the error, google play store is ended every time i open it.

You can try to reboot in recovery again and wipe Dalvik cache. Not sure at all it will do the trick but…

Disable location and try again.
There seems to be a conflict.

thanks freibadschwimmer. it worked…Thanks everybody…

A post was split to a new topic: FP Open OS: FP doesn’t charge, but freezes when turned off

Very much thanks to all the team

Thanks for the tips particularly microG Project

1 Like

Update went smooth using method 1 in the instructions.

If you’re done using Fairphone Open Source OS, you can always go back to Fairphone OS.

Method 1: Using Fairphone Updater
This is the easiest way to go back to Fairphone OS. Make sure you are connected to a Wi-Fi network before you start.

  1. Open the Updater app.
  2. Tap ‘Enter advanced mode’.
    3 …

I want check this option but i can´t find “Enter advanced mode” in Updater app.

1 Like

Hello everyone!
Just one question : is the GPS working in the os os?

GPS works fine for me. Usually I get a fix within seconds. Sometimes it takes a bit longer and sometimes SatStat says that I’m already connected to a few Satelites but I still don’t have a fix. All in all my worst TTFF (time to first fix) was about 1 minute.

Advanced mode is missing for me too, but I think it’s already like this since FP OS 1.2.8

@paulakreuzer How can i go back to Fairphone OS?