English

Fairphone 2 not staying connected to my home wifi

Hello! I am not sure about router technicalities but on the back its says the following:

Arcadyan
Experia Box V 10A

Here a picture of it:

I have never updated the firmware on a router so do not know if it is possible with this router?

Hi thanks for this, I really do not know how to change the setting on my router because there only seems to be a couple of buttons including the power button. How can I make the changes that you mention?

I tried making the changes in the phone but sadly this is didn’t work :frowning:

Thanks anyway!

For those who cannot view the photo: It shows the type label of a SOHO router, model “Arcadyan Experia Box v10A”.

Please have a look at this post: https://forum.kpn.com/internet-9/firmware-update-v10a-v5-00-31-build420-485099

2 Likes

About the picture. I wouldn’t put a picture on a open forum which contains all keys to my wifi, as well as the admin password. I would suggest you edit the photo and blur these fields (just a suggestion).

@conniejehu, I hadn’t thought about it before, but is your phone up to date?
When you go in the updater app, is it version 19.11.2 (last version available)?

2 Likes

I would have expected that the admin password has been changed already. If not, I second your thoughts.

OK thanks! I took it down! Thanks for the tip. Just really desperate to fix it!

1 Like

ha! Weirdly my phone has just suggested the update. but i need to be connected to the wifi to download it :woman_facepalming:

Well… I wouldn’t investigate further before you update.
The 19.11.2 version solved a lot of wifi problems of the type you describe. So either connect to mobile data to download it, or use another phone to do a bluetooth tethering, or use a computer to do adb tethering, or try to find a wifi which connects without problem… i.e find a way to download this update.

As @DeepSea gave the reference of the router underneath, it is probably better.

2 Likes

Yes, version 19.11.2 of FPOS is a must for those who experience WLAN issues…

1 Like

My quick workaround is to use FLIGHT MODE switch to reset WiFi connection.

My wife and I had the same problem with our FP2’s (with 19.11.2 of FPOS) with the experia box v10a. But also my laptop regularly disconnected from wifi (but it automatically reconnected, our FP2’s did not, for that I had to switch flight mode on and off). I called our internet provider and they said they heard this problem more often with the experia box v10a. They told me to play around with certain settings but it did not solve the problem, so in the end they gave us a wifi extender and now we hardly have this problem anymore.

1 Like

Unfortunately WLAN is not one of the strenghts of the FP2. My wife has a Pixel 3a, the WLAN connections on her phone are much better compared to the (old) FP2. (Our phones are running Android 10.)

1 Like

Based on my experience with my FP2, no matter the OS, I agree with @DeepSea (though that doesn’t mean that all FP2s have wifi problems).

1 Like

I had WiFi problems with my FP2, but not this one (random disconnection) until now, when staying in self catering accommodation. Everyone else’s devices are fine, but my FP2 will not stay connected, and often will not reconnect when ordered to (via More Options > Connect) unless I reboot. Essentially, unusable.
If this persists when I get home I shall have to replace the phone, so disappointing!

For what it’s worth, I was having similar problems and solved them by configuring my router to use a fixed channel for the 5 GHz band. It seems like the FP2 (and also FP3 apparently) don’t like the higher channels (116-128) very much, so if your router switches channels automatically and lands on one of these, your FP2 loses connection seemingly at random. See my topic here for further details.

I have a similar problem at the moment - it won’t connect at all to my home wifi. This only happened in the last week, I don’t know why. It started to drop out so then I told it to forget the network and reconnected, entered password (I checked I had right password - did the same on my Mum’s Samsung mobile and it worked), but it just won’t connect and says “Authentication problem” and that the password may be incorrect…I have checked multiple times, the password is definitely correct! I don’t know if this is relevant but on the Configure Wi-Fi screen under MAC address it says IP address Unavailable. Please help!

Reset your modem and try again to connect.

Hi,

just to share my point of view: We have three FP2 at home and all of them regularly (every 2 - 10min) disconnect from WiFi. Most of the time they reconnect within seconds, but sometimes we have to deactivate and reactivate to reconnect. Very annoying.
There are discussions that it might be related to IPv6 (eg https://support.google.com/fi/thread/704246?hl=en). We have only an IPv6 connection at home (UPv4 tunnelled) so most of the network traffic at home is IPv6. Unfortunately I did not manage to disable IPv6 in our LAN.
Might be worth a try.

Regards, FM

Hi,

Just to add to the solution: we have a FP2 with the same problem. Disabling WIFI-Scanning and Bluetooth-scanning for location did solve the issue for Build-number 19.11.2, Android 7.1.2

Edwin

1 Like

Thanks for sharing your solution. I have Lineage OS that basically does not use WiFI to scan for location, but I sometimes experience the issue as well.