Fairphone 2 does not get bluetooth connection with WITHINGS Pulse Ox

I own a Fairphone 2 since 5 weeks. I use LineageOS 15.1. The 1st two weeks everything was working fine. Since the 3rd week my fitness tracker Withings Puls Ox lost its bluetooth connection. I tried to create a new connection. Healthmate shows the name, but creates no connection. I tried it with my Samsung Galaxy S6 (original rom) and it works.
When I first got the Fairphone device, I installed LineageOS 14.1. Then I connected some bluetooth devices like Withings BPM, Toyota Touch, Earphones and Withings Puls Ox. All devices work properly. Then I upgraded to 15.1 and it worked fine too. But Puls Ox suddenly does not. But it still works with Samsung S6. Yesterday I received a new Puls from Withings, because I was convinced of a hardware fault, but the new one shows the same fault with Fairphone and works with S6. Does anyone have an idea ?
Today I tried it with my old Samsung S2. With Samsung firmware Puls works fine, but with LineageOS 14.1 it doesen’t.

Ah, the much-loved Bluetooth again :slight_smile:

  • Have you turned the phone off and on again (real shutdown, not just a reboot)?
  • You could try whether pairing works again after deliberately “forgetting” the device in question on the phone:
    Settings - Connected devices (Bluetooth, Cast) - Bluetooth - (cogwheel for paired device) - Forget
  • Somewhat radical (at least it sounds that way, I never needed to do this):
    Settings - Network & Internet (Wi-Fi, Mobile, Data Usage, Hotspot) - three-dot menu - Reset Wi-Fi, mobile & Bluetooth - RESET SETTINGS
  • Settings - Developer options (to activate these, tap on Settings - System - About phone - Build number several times) - Enable “Show Bluetooth devices without names (Bluetooth devices without names (MAC addresses only) will be displayed)”

thank you for your quick reply !!!

  • yes, I have switched it off with TWRP and removed the battery
  • I have removed all paired devices
  • RESET SETTINGS did not solve the problem
  • there are no bluetooth devices without names.

For using the withings bluetooth devices a manually pairing is not needed. You only need the Healthmate app and a Withings account. The devices are installed within the app. There are no entries of bluetooth devices inside the bluetooth menu. I use the blood pressure monitor too. If I switch it on, the connection will automatically be established and Healthmate opens automatically too. With the Puls Ox device it should be the same, but it will not be detected by Fairphone2. If I try to create a manual connection it is created, but Healthmate ignores it.
With Samsung S6 both devices are detected and the App establishes the connection.
This morning I tried it with my old Samsung S2 (stock rom). It works. Then I installed LineageOS 14.1 on S2 and it does not work. I think its an issue with LineageOS an not with Fairphone2.

I’m not sure if it’s related, but with FP2 + LineageOS I cannot pair with a UE Boom speaker. It does work with speakers by JBL though. If there’s anything I can do to debug this issue, let me know, maybe it’s the same root cause.

Concerning audio via Bluetooth … there are some settings in the developer options about codec versions or else …

Settings - Developer options (to activate these, tap on Settings - System - About phone - Build number several times)

Thanks, good to know. In this case it’s probably not about the codecs, since pairing already fails.

My last successful connection between Fairphone2 and Withings Puls Ox was on 12st of January. I think Withings did an automatic Update and after that the connection was lost. When I received a new Puls from Withings, the first connection was successful. But after a short time an automatic update started and the connection was lost. I still can pair it in the bluetooth menue. It takes a long time, but paring is successful. Only the Withings App “Health Mate” does not synchronize with Puls. With Samsung S6 and stock rom it works.

I had contact with Withings customer service about this issue. But they told me, that LineageOS is not supported. I asked them to rollback the update, but they told me, that it is not possible. They will contact me if they find a solution.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.