Fairphone 1 screen alternating between blue and black

I browsed the search funtction and didn’t find a clear answer to my problem, though I have a hunch.

My problem: my fairphone screen is alternating between black and blue with a frequency of roughly 5 seconds. No reaction to power button use. Connecting a power cable produces a short LED flash, but afterwards the alternating screens continue.

What I tried: removing and reapplying the battery didn’t change anything. I can reach the sleepy robot (recovery menu), though pressing the power button does not open a menu there.

My hunch: from what I read on the forums and the support page I guess it’s the ‘internal power button’. Before opening up my phone (and trying to find a soldering iron for rent) I just wanted to check if someone had a different, less invasive approach first.

Thanks in advance for all your help!

At what point is it flashing? When you try to turn on the phone, or when you do not press any button at all?

Do you refer to the LED flash? That happens only when I connect a charger, the moment I connect it and it’s a single short flash only.
The alternating between black and blue screens happens as soon as I insert the battery (no button pressed) and only stops when I enter the recovery menu (or remove the battery).

I meant the alternating screen - I understand it is slower, not “flashing”. That is indeed a motherboard defect and most likely the internal power button issue you described, so you need to find someone to solder a new button on the motherboard (since spare motherboards are not really available right now).
A possible solution is found at FP1: Power button does not work anymore

Just in case someone else deals with the same problem at some point, here is what I found out so far:
I had the power button replaced without any change in behaviour. As far as the technician in the shop could tell it is a problem somewhere else on the mainboard, but he couldn’t tell where exactly (there is no further visual physical damage). I will probably try another shop in my neighbourhood over the weekend.

I have the exact same problem since yesterday. For several days my phone was rebooting and I could use it almost normally but since yesterday, I cannot turn it on anymore.
Have you found a solution yet ?

I have exactly the same Problem since today. It happend once before a few month ago, but stopped when I connected my phone to the charger. This time that doesn’t work. Have anyone of you found a solution so far?
Thank you!

Have you tried the solutions proposed above? You can test for a broken power button if you take out the battery, put it back in, and it starts to flash blue/black by itself.


I just experienced the same exact problem. After I took the sim cards off my FP1 and I inserted the battery again, without turning on the phone or doing anything, the screen just started turning blue for a few seconds then black (off) for a few seconds, then blue again, then black, and so forth until I remove the battery.

Turning on the phone through the power button is impossible. If I boot into recovery mode (resting robot, no command displayed) the power button seems not to work anymore, meaning I can’t enter the menu as explained here. If I wait on the no command screen after a while it goes back to its black/blue shifting.

@Lidwien did you encounter the same problem, and how did you manage to make the power button work?
@paulakreuzer any additional idea?

I thank you a lot in advance for your advice! I would really like to keep this FP1 functioning for another while.

1 Like

My powerbutton was working well.

If you can’t turn your phone on through the power button, how do you boot into recovery mode?

1 Like

Hi thank you for replying so quick!

Well that’s the thing, I think the power button is working as I can get into recovery mode. It’s only that once I’m in recovery mode it doesn’t work anymore. I have no other way of testing this as I can’t do anything but boot into recovery! :frowning:

I believe the power button might be stuck. I don’t know how to fix that though. Maybe a #repairshops can help.

1 Like

Hi Paula thanks for your reply! I thought so too at first but then it would be impossible to boot into recovery, which I am able to do every time. Also, I read on one of the support pages that the blue/black screen issue can be caused among other things by an old sim card, leading me to think that it must be a software issue. Maybe some malware? Is there anything else one could try besides a hard reset via recovery boot?

Thank you again for your help!

If the power button is stuck then you get to recovery mode simply by pressing the volume up button.


Would that explain also the blue/black screen at the beginning you reckon? As it’s stuck it might constantly give an on, off, on, off, on, off, etc. command?

Maybe, though I don’t remember a blue screen being a part of the normal boot sequence of the FP1, so there may be something else going on (too).

1 Like

Ok thank you a lot for your help, I really appreciate it!

Did you try to remove the black part of the power button and then clean and put the black part back.
Perhaps there’s some dirt.

1 Like

I would also say that the power button is broken. As a matter of fact I just tried constantly pressing my working power button on my FP1 and the phone screen flashes on/off with a delay of roughly 5 or 10 seconds (not too fast). I run #kitkat so there is a black screen with white Fairphone logo alternating with a completely black screen.

Here is some more information that could help you or a repair shop to repair the phone:


Wow ok I will try this, thank you so much @Lidwien and @Stefan :slight_smile:

1 Like