Facebook app causing severe problems (December 2016 app update)

Still going on for me.

Used to be able to do this no problem. Not sure what has changed but now I can’t upload to Facebook at all. Phone just freezes, restarts by itself…does not upload anything. I’ve unistalled and reinstalled Facebook, have also cleared data, cache all that…still nothing. I can see the loading tab on the Facebook app, gets to 42% then just stops. Very frustrating! Can anyone help? I’ve tried unticking box on privacy impact as that seems to have worked for people, but it has made no difference :frowning:

I moved your post here - you’ll see you’re not the only one with FB issues. It’s best to uninstall the official app and try an alternative.

The privacy impact thing was a bug that was fixed a long time ago.


I have the same issue. However, the phone doesn’t freeze, but just reboots 4 seconds after starting the Facebook app. After the reboot, I can use the app again for a while. And a few hours later I have the same problem again.

Yes I do think that lots of my problems are down to the FB app. But not all by any means. It ALWAYS seems to reboot when it wants to update an app. Nothing to do with facebook. Any ideas what this might be?

Did you uninstall FB? Only then you’ll know if it indeed has nothing to do with FB, in which case please continue here - as this is not the right topic for you then.


Just scrolling down the FP1 forum I’m coming to the same conclusion. It’s looking like an experimental platform for survivors and experts, rather than a viable smartphone.
Mine started with Facebook, I’m now running Tinfoil but that’s not without its problems (copy and paste a web page? - not easy matey!) And Twitter is almost unuseable too; if you don’t do things in a very prescribed order, you’ll get hourglass and unsent tweets.
I’m reluctantly contemplating replacement, after all it’s 2 1/4 years old and therefore obsolete, right?

Obviously you looked in the wrong places! :wink:

Not Fairphone’s fault! Issues started with an update of the Facebook app: Facebook app causing severe problems (December 2016 app update) You could try to roll back to an earlier version of the Facebook app (APK Mirror is trusted by a lot of people since they are run by AndroidPolice.com).

There is a very powerful (and open source!) Twitter app out there: https://forum.fairphone.com/search?q=twidere

1 Like

Hi Stefan, yes I know it’s not Fairphone’s fault, it’s just that the world has moved on since Android 4 and new stuff doesn’t work. I’m not gutted that I can’t post on FB in lurid colours… I took the advice to use Tinfoil but as I say, that has its bad days too.
Will try your Twitter suggestion, thanks.
But it does look like the FP1 is heading surely for the door

I, personally, see it the other way round. Facebook doesn’t respect my lifestyle because I don’t want to buy the latest gadgets, but they are trying to force me to do it. An open network would allow me to use legacy app versions to access the network.

PS.: I’ve been using my Fairphone 1 for 3 years (most of the time even without Google Apps).


I don’t approve of built-in or forced obsolescence, but it happens.
My laptop is slow and clunky on internet access, all of 3 years old. Also does good impression of fan heater… Resisting the urge to replace.

I suggest you to listen to this podcast: https://therestartproject.org/podcast/ssd/ I replaced the hard drive of my laptop with a SSD and it runs like on the first day! (I also upgraded to Windows 10 in the progress, but you could go for Linux or skip this part at all.)

PS.: My Windows Task Manager says:

Last BIOS time: 2.7 seconds.

1 Like

I’m now using Tinfoil for Facebook, it’s easily crashed (e.g. clicking on a Message notification closes it) and it doesn’t like pasting links into a post, but otherwise it does mean I can still access FB on my FP1.
Now I’m having Twitter problems too. Their app (v6.29.0) takes ages to load, and until you’ve waited for the Feed to refresh and update, you can forget about clicking on Notifications, it just won’t load. After reading those, don’t click Home, click Back, or it will also get upset.
So, are there any fixes or alternative platforms to access Twitter?

There is Tinfoil for Twitter too.

Facebook is at it again it seems.
Browser or Tinfoil, the problem is the same.
Opening FB the page sticks at “Loading…” but the word and its progress icon are double printed, like bad specs!
Notifications page loads, but clicking on a notification brings up another blank screen.
And that’s all I can do with it!

Which browser have you tried? Tinfoil and the preinstallled browser both use the insecure Webview engine, AFAIK.

Phone browser and Tinfoil only.
Is there another I can try?

Yeah, check out the browsers section of the link I posted above. :slight_smile:

I’ll let you know how I get on!

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.