F4 wifi pairing GoPro Hero9

Hello everyone,

I found a topic for a user struggling to connect F3 to his GoPro, but the solution there didn’t help my case. I hope there are action camera users here who could help me out.

I haven’t been able to connect via the camera’s wifi to view the video content, sync it or update the firmware via the QUIK app.

Until now I have managed to:

  • manually update the firmware of the gopro (it didn’t work via the QUIK app because connecting to the camera’s wifi was impossible), but that didn’t solve the issue
  • i tried different wifi frequencies (5G or 2.5G)
  • i manually connected to the wifi of the camera, but that also didn’t help
  • i was in contact with GoPro’s support and they blamed it on the phone model
  • my F4 is up to date and restarted multiple times
  • for the record, the camera pairs successfully with the phone/app when connected via Bluetooth. The issue is that for viewing the shot content and making updates, it all needs to happen via the camera’s wifi. It just enters a loop of trying to connect. Often there isn’t even an error, it just keeps trying to connect.

Has anyone had such issues? Do you have tips on what I could try?

Thank you in advance! :slight_smile:

A post was merged into an existing topic: I tried to connect to my GoPro 9 through Quik app of GoPro, I can’t connect