Error downloading apps from Play Store

Whenever I try to download and install an app from Google Play Store, I get this error message: “Error retrieving information from the server. [RPC:S-7:AEC-0 7SIV-UMRW-JSSGM]”, with the post the space part varying each time. The errors occur regardless of whether I connect via Wi-Fi or my regular network. Any suggestions what to do? Cheers!

On google I find the following suggestion:
Go to System settings, Apps, Google Play Store, clear data and clear cache
Go to System settings, under Accounts choose Google, tap on your account, tap left at the bottom, remove your account
Stop and start your phone
Go to System settings, under Accounts tap on + Add account, add your account at Google

Retry to download and install an app from Google Play Store

Thank you for the suggestion. It didn’t fix the issue, though.

Try uninstall updates in the app the Google Play Store.

Still no luck. I found a couple of frustrated forum users online who had also tried a factory reset and had by now resigned themselves to waiting for Google to come up with a solution.

You might want to try (re)installing the latest Fairphone update?

After that you will of course need to reinstall the app store again.

Tip: while downloading the update/app store make sure to keep your screen activated otherwise the download might fail.

Hey, thanks for the reply. I evidently wrote off prematurely the factory reset, which did the trick last light.