Encryption unsuccesful error

My FP2, Android 10, has developed an Encryption unsuccessful error and has become unusable. It tells me I need to do a factory reset. Removed the unused SD card. Tried safe mode. Didn’t help.
I would like to avoid a factory reset.
I’m aware of 3rd party software ( iMyFone Fixppo for Android) that claims it can solve the problem. Does anybody have experience with this?
Any other suggestions or solutions? Thanks!

I have had the same issue some time ago with Lineage OS and indeed the only thing that I could do at that time was to do a factory reset and set everything up from scratch again - I didn’t have the time for experiments unfortunately.
Here is the short discussion that I started at that time:

1 Like

I have no experience with this software (and never heard of it before). I took a quick glimpse at the website, but there is no description beside some simple steps:

  1. Select Device Information
  2. Download Firmware
  3. Connect Device to PC & Repair It

So I assume the software does nothing but reflashing the firmware, maybe there are some problem related tweaks implemented. If no one else used it successfully before, I would contact their support and reassure that your data isn’t lost. But to be honest, it sounds to good to be true… Haven’t found any other solution and I can’t think of a way for the software to backup the data from an inaccessible partition.


I had the same feeling about Fixppo.
@Martin_Anderseck : looked at your thread and saw TWRP mentioned. Looked into this (twrp.me), but I don’t have a clue what to do with it.

Was this SD card installed as expansion of internal memory or as external / portable? If the former, could have been a contributory factor in the encryption bug, even if unused.

I agree.

I’m not sure. It never worked well and I have tried to use it for a long time. Now, I have removed it.

I’ve already done a factory reset (I’m in a hurry to be able to use the phone again). Still interested in more elegant solutions for the future.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.