English

EFIDroid (multiboot) for the Fairphone 2

Thank you, I will try this evening.

1 Like

Hello. I tried two times. First time no change, but I can power off the
phone again. Second time I format system, cache and dalvik: no more
warning during zip install! But no more boot in Open OS…
Back again to job: thank you a lot, have a good day!

@z3ntu do you think it could be possible to add an option to boot to the charging animation?

The biggest problem I have with EFIDroid is that when my battery is deep-discharged it’s a hassle to load it again. When I plug in the dead phone EFIDroid starts automatically and it stays fully lit all the time without showing a battery percentage (the LED doesn’t light either).

Now when I try to boot to early it just gets stuck, so the best workaround I got so far is: Wait about 10 minutes and then boot to FP OS’s TWRP (I have the feeling it boots faster than Open OS’s TWRP - does that make any sense?). There I can see the battery percentage & LED and the screen goes black after some time so charging is much faster.

Hello!

I wanted to try FP Open and followed the instructions in https://z3ntu.github.io/2016/11/01/Install-and-configure-efidroid.html

However when I reboot into EFIDroid I have no TWRP entry under the “Recovery” category, instead there is “Recovery (internal)”.

Do I need to install TWRP before installing EFIDroid?

Regards, pesche

TWRP would be better but the stock recovery should work too theoretically (never tested it with it though)

With the stock recovery EFIDroid selecting “Recovery” just boots into EFIDroid again.

So I tried to install TWRP 3.0.2 from the ✏ Porting TWRP recovery thread, but couldn’t get it to be flashed permanently (even with the Volume Up Button: TWRP is shown, but after I reboot it has vanished again).

Do I need to unistall EFIDroid to install TWRP permanently?

Answering myself… After powering off EFIDroid showed the TWRP recovery, so this worked.

When installing the FP Open 16.12 image however there was a red Failed to mount '/system' error message and trying to boot into FP Open just lands in EFIDroid again.

From TWRP: Unmount /system, format /system and finally unmount all partitions and then install the zip.

Thanks, z3ntu. However I just made a backup with TWRP and installed FP Open OS without EFIDroid. I hope I don’t need FP OS anymore.

@mal - said there is absolutely no problem to switch between Fairphone Open and SailfishOS just with reflashing the needed kernel (boot.img)

Is it possible to integrate this function EFIDroid ?

To keep it short: SFOS isn’t supported at the moment but hopefully will be in the future . You can message with the creator (m1cha) eg on Slack and discuss every possibility with him or just wait :wink:

1 Like

Unfortunately i’ve run into the same Problem. I’ll see if I can try the solution proposed by z3ntu.

Did you download the full image, not only the incremental update?

Maybe you’re right. That was the problem. I had tried FP2-gms70-1.10.1-ota_from_open.zip from https://code.fairphone.com/projects/fp-osos/user/fairphone-open-source-os-downloads.html#download-releases. Suppose that was wrong.

I can just says that I myself didn’t have success with FP2-gms72-1.11.1-ota.zip

1 Like

Would be great to have also ubuntu-touch and Fairphone Open in dualboot with EFIDroid. Has someone experience?

It 100% doesn’t work as a second rom right now. It could maybe work, if you install EFIDroid (from Android), create a second rom (from Android), flash Ubuntu Touch (via recovery/fastboot), put the boot.img from Ubuntu Touch into the correct location (don’t know where right now), flash the boot.img from EFIDroid and then theoretically it could maybe work. :wink:

That would be my preferred way. What I tried is the following:

  • Installed EFIDroid in my FPOOS
  • Added another OS (ubuntu touch)
  • Rebooted in EFIDroid --> Fastboot --> ubuntu touch
  • And than maybe I used too much automatism with using the Magic Device Tool
    In the mdt script is one line
    fastboot format cache fastboot format userdata fastboot format system fastboot reboot-bootloader

and after that flashing the ubuntu touch recovery and boot image. Maybe that is the mistake.

Here you can see the mdt script.

Ubuntu Touch as a secondary rom isn’t supported yet but I meant that it might work as the primary rom.

Ah! Do you ha an idea how to try to configure it in EFIDroid?