English

EFIDroid (multiboot) for the Fairphone 2

multiboot
Tags: #<Tag:0x00007f9ff8de7f98>

#21

System partition “is” unticked in TWRP and I can’t modify that. I can only thick “Mount system partition read-only”. I tried and I got several “Fail to unmount ‘/system’ (Invalid argument)” messages. I format dalvik and system cache but when I try to boot into Open OS I see Fairphone logo, then back again in EfiDroid.
Another thing, now I can’t power off my FP2, only reboot.
@paulakreuzer There is no prompt asking for permissions at all.


#22

Uhm… I am out of ideas unfortunately…


#23

I don’t know if this prompt is related to your issue, but if it is try rebooting from within TWRP, that usually triggers the prompt if you haven’t seen it yet.


#24

@z3ntu and @paulakreuzer Thank you for your help!


#25

Did you solve your issue?


#26

Sorry, I say “yes”, because I think we can’t do much more for now :slight_smile:


#27

So I just tried again and if you get that system error, unmount the partition, format it, try to mount it, that should work, unmount it again and flash the zip. I tried it with FP Open 16.12 and it worked fine.


#28

@paulakreuzer Why can’t I edit my original post anymore?

Also general: I tried flashing FP2-gms72-1.11.1-ota.zip but I just get a forced reboot (last_kmsg is corrupted as always)… FP Open 16.12 is confirmed to (at least) boot.


#29

I wikified it so that you can edit it.


#30

Hello! Can I safely format /system partition without losing data in FPOS
install?


#31

If you chose a secondary rom when booting into TWRP, yes. Otherwise, no (then you will format the primary roms system partition).


#32

Thank you, I will try this evening.


#33

Hello. I tried two times. First time no change, but I can power off the
phone again. Second time I format system, cache and dalvik: no more
warning during zip install! But no more boot in Open OS…
Back again to job: thank you a lot, have a good day!


#34

@z3ntu do you think it could be possible to add an option to boot to the charging animation?

The biggest problem I have with EFIDroid is that when my battery is deep-discharged it’s a hassle to load it again. When I plug in the dead phone EFIDroid starts automatically and it stays fully lit all the time without showing a battery percentage (the LED doesn’t light either).

Now when I try to boot to early it just gets stuck, so the best workaround I got so far is: Wait about 10 minutes and then boot to FP OS’s TWRP (I have the feeling it boots faster than Open OS’s TWRP - does that make any sense?). There I can see the battery percentage & LED and the screen goes black after some time so charging is much faster.


#35

Hello!

I wanted to try FP Open and followed the instructions in https://z3ntu.github.io/2016/11/01/Install-and-configure-efidroid.html

However when I reboot into EFIDroid I have no TWRP entry under the “Recovery” category, instead there is “Recovery (internal)”.

Do I need to install TWRP before installing EFIDroid?

Regards, pesche


#36

TWRP would be better but the stock recovery should work too theoretically (never tested it with it though)


#37

With the stock recovery EFIDroid selecting “Recovery” just boots into EFIDroid again.

So I tried to install TWRP 3.0.2 from the ✏ Porting TWRP recovery thread, but couldn’t get it to be flashed permanently (even with the Volume Up Button: TWRP is shown, but after I reboot it has vanished again).

Do I need to unistall EFIDroid to install TWRP permanently?


#38

Answering myself… After powering off EFIDroid showed the TWRP recovery, so this worked.

When installing the FP Open 16.12 image however there was a red Failed to mount '/system' error message and trying to boot into FP Open just lands in EFIDroid again.


#39

From TWRP: Unmount /system, format /system and finally unmount all partitions and then install the zip.


#40

Thanks, z3ntu. However I just made a backup with TWRP and installed FP Open OS without EFIDroid. I hope I don’t need FP OS anymore.