/e/ OS installation: Which version is correct?

Hi everyone,

after spending at the PC for several hours trying to install /e/ OS on my FP3+ and reading different threads in the forum I decided to sign in here myself and start a new question.

I bought a FP 3+ second hand with pre-installed Android 11.

They say on https://doc.e.foundation/devices/FP3/install

Caution: Do not install /e/OS on top of a higher version of stock OS. Before installing /e/OS ensure your device has the latest stock OS of the same version as /e/OS. If only lower versions of the stock are available then install the last available lower version before installing /e/OS.

But when choosing a version here I find only Beta-Versions for Android R.

After several struggles as well with the easy-installer as with the step-by-step installation (both broke down or interrupted the process at some point) I wonder if I cose the wrong version by trying “IMG-e-1.2-q-20220728206708-dev-FP3.zip”.

Do I have to downgrade my Android first? Or is there any easier option?

Thanks for any ideas.


Do you have error messages from when installation broke down (or log from easy-installer)?

1 Like

You might already know, but this is an Android 10 version (the letter Q indicates that).

In your scenario, if you definitely want to switch to /e/ now, go for the Android 11 beta. /e/OS Android 10 has been in beta until just 2-3 months ago, and I have used that beta for months and months before and found it completely usable (even though I was even on the dev-version). I think @Volker has been using the FP2 /e/OS beta for much longer.

  • The easy-installer broke down every time when trying to detect the phone

  • the step-by-step installation failed on command

fastboot flash system_a system.img -S 522239K

So your suggestion would be the “IMG-e-1.2-r-20220727206630-dev-FP3.zip”?

Yes, although I will admit I still haven’t upgraded to it myself (I’m using /e/OS Android 10 dev) given I expect an OTA upgrade some time towards the end of the year (hopefully :wink: ).

In doubt, trust @Volker who is our main /e/ expert here.

1 Like

Are you sure that unlocking the bootloader had worked?
Do you have an error message you got after typing in the fastboot command?

EDIT: Rereading about your problems (and that easy installer did not detect device): when you start the fastboot mode of your FP3 and type in fastboot devices do you get a device-ID back? Are you using a USB data cable (is data transfer between your PC and the FP3 possible)?
Are you trying to install from a Windows PC or Linux? It might be a driver problem if device access is not possible.

1 Like

Yes, that’s what I’d install. I’d rather not wait for on OTA upgrade from q to r…

1 Like

I use Windows 10. In the Explorer I find the FP3 as drive.
Yes, bootloader is unlocked.
fastboot devices fails.
!UPDATE: No, sorry it works! Device-ID is transmitted

The Error messages at the installation are different.
a) Sometimes “wating for device” (although I checked USB-Transfer)
b) sometimes reading error
c) sometimes writing error

Strange. Did you try out

  • a different USB cable
  • a different USB port
  • a newer fastboot version (is there is any; what’s the version you’re using?)

And it always fails on the first flashing command, right (i.e. system partition; wiping userdata using fastboot -w is still working)?

1 Like

He edited the most recent reply in the meantime. Let’s see, maybe there’s progress by now. :slight_smile:

1 Like

OMG! I think I got it!
I’m afraid I never went back to the fastboot mode after unlocking it i nthe first place. That way I tried to install the new OS while running Android. How embarassing! But now it seems to work out.
Yes, thank you very much.

As you suggested above I habe chosen the Beta version (Andr. R) now


Great, you’ve found the culprit and I hope you’ll enjoy /e/OS!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.