English

Dual sim after marshmallow update?

Hi All,

Since upgrading to marshmallow my phone only has 3G and 4G as options for the first sim slot. Previously, I could set the first sim to 2G and then my second sim to 4G but now that I can’t set the first sim to 2G, my second sim is stuck in 2G. Since I travel between two countries frequently it was really useful to be able to swich which sim uses 4G with out taking the sim card out.

Is this a marshmallow problem? Has anyone had similar problems? Is there a way round it?

Thanks,
Lorna

3 Likes

We currently have a bug logged for this

Are you able to change the 2nd SIM to anything other than 2G?

2 Likes

No. It is stuck on 2G.

Just to check, if you change 4G to 3G on SIM one, do you get any option to change SIM 2 to 4G or is it only showing the option of 2G?

1 Like

After swapping sim 1 to 3G, I still wasn’t able to change sim 2 from 2G. I tried turning it off and on again after swapping sim 1 to 3G. This also didn’t help.

Thanks for your help btw.

1 Like

Bizzarrely, I just swapped my sims around and it remembers which sim was previously set to 2G. This means even if I swich my sims manually, I still can’t set my italian sim to 4G. So this is a much bigger problem than I originally thought.

If anyone has any idea how to get my italian sim set to 4G by any method, I’d be really greatful.

Thanks,
Lorna

Could be related to:

I have the same issue as Lorna – I can now only swap SIM1 between 3G and 4G and SIM2 is stuck on 2G, which is annoying as SIM2’s network (Three, UK) has no 2G network at all. I usually want SIM1 on 4G and only activate/swap the 4G to SIM2 when I need to use its data instead, and I can currently no longer do this :frowning:

1 Like

Just for testing purposes: Can you set 2G to SIM1 and then select 4G for SIM2?

I’ve found a way round this:

Go to SIM cards in settings. Deactivate the sim that you don’t want to be 4G. Then go to More, mobile networks. You should now be able to change the active sim to 4G. After doing this, go back and reactivate the non-4G sim card.

5 Likes

Good approach and perhaps a valuable pitch for the developers. Thanks for sharing!

1 Like

No; as I said the only options for SIM1 are 3G and 4G.
Lorna, thanks, I will try that out!

This option didn’t work for me, but thanks Lorna for sharing.

I’ve just got a second sim, and have discovered I have this problem where I’m unable to select 2G for the first sim. I’ve tried the various suggestions above such as disabling the sim or selecting 3G to get 4G on the second sim, however non work.

Is there an update available on when this issue is likely to be fixed please?

Lorna’s trick did work for me, but I need to reboot the phone after the first step in order for it to work. So my steps are:

  1. Deactivate SIM1 I don’t want to be 4G (which has options 4G/3G only)
  2. Reboot phone
  3. SIM1 now has “2G” option! Set it to 2G and set SIM2 to 4G.
  4. Activate SIM1.
  5. Going back, can set SIM2 to 2G and SIM1 to 4G, but again it will only have 4G/3G options, so have to repeat next time I want SIM2 to be 4G.
3 Likes

I found taking out the sim temporarily and rebooting would allow me to tap the 4G option to switch. I could then put the other sim back in, however no 2G option was shown.

I’ll try deactivating the sim and rebooting to see if that method works soon.

I have nearly the same symptoms as @dracos , in that some SIMs only permit 3G/4G, and I have to deactivate them then reboot to see a 2G option, to enable 3G/4G on the other. But it seems to be controlled by the SIM card, not the slot:

I tried Three, Vodafone and Lyca SIMs, in either slot, and they permit 2G/3G/4G. I also tried giffgaff and Virgin, and they only permit 3G/4G.
So when I have either the giffgaff or Virgin SIM in use, and set it to 3G/4G, I have to go through the deactivate-and-reboot process when I want 3G/4G on the other SIM.
But when I’m only using Three, Vodafone or Lyca SIMs, I can still switch both between 2G and 3G/4G without having to switch anything off.

(These are all UK SIMs.)

1 Like

It looks like giffgaff have acknowledged the problem (on Android 4.4 at least):

However, their fix of going in to the diagnostic menu doesn’t seem to change anything for me - possibly doesn’t work on a dual SIM handset?

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.