Switch 3G and 2G between SIM cards

Not sure if it’s related to this, but I now can’t switch 3G/4G between SIM cards. I used to be able to drop SIM 1 down to 2G and then enable 3G on SIM 2. Has anyone found a way to switch between them?

I have switched last week my 3G/4G SIM from SIM2 to SIM1 and back to SIM2 (my data plan was nearly used up) with 17.04.8.

So it is not a general problem.

Do you have the problem a) that the 2G option is greyed out or b) that the mobile data is not working or c) that the preferred SIM stays on 2G although 3G/4G is switched on?

Previously in Settings -> Mobile Networks I could drop SIM 1 down to 2G and then enabled 3G/4G on SIM 2. Since 17.04.8 the only options on SIM 1 are 3G and 4G - there’s no option to drop it down to 2G. This means that the Preferred Network Type option on SIM 2 stays greyed out.

I have a similar issue. On previous software, to use 4G, you needed the second SIM set to 2G. On Android6, the release version, the only options are 3G/4G on each sim. At time of upgrade (day after release) I had sim1 on 4g and sim2 on 3g.

My SIM1 which I want 4G on, only ever shows “3G” as actual data speeds. I tried setting the SIM2 to 3G, but it never takes - I click the radio button, and but 4G remains set. I’ve tried this repeatedly, and also disabling and re-enabling SIM2.

Any tips? Is there another setting in android6 which we should change?

No, I cannot reproduce this problem. But I had upgraded via 17.04.3 and had SIM1 on 2G and SIM2 on 4G during upgrade.

So I think this problem occurs

  1. either when SIM1 is on 4G during upgrade
  2. or when SIM1 is on 4G during boot
  3. or when the upgrade was directly from Lollipop to 17.04.8.

Problem (3) could theoretically be solved if you install the full image of 17.04.8 over your installation. (That full image is accessible via the “advanced” section of the updater.)

I have this problem since upgrading to android 6 (17.04.8)

  • sim1 slot greyed options (appears to be fixed to 2g)
  • sim2 slot only have 3g & 4g available

Switched sims around…

  • sim1 slot with secondary sim card, not greyed out only 3g & 4g
  • sim2 slot with primary sim card, not greyed out out only 3g & 4g

however I am not able to select any options - not savable.

Switched sims back, still the same as at the beginning.

“Go to settings>>apps>>Scroll down to settings>>tap on storage>>tap on clear cache and clear data”

I am not able to to either, it falls over! I even attempted this in safe mode - no go.

My final attempt was to reinstall as commented:

this fails too. It will not overwrite it.

any tips on the next step I should take please

I tried resetting the network settings and also a full reinstall of 17.04.8, and I’ve managed to get SIM1 to be 4g, and SIM2 2g. This is good!

Except, I don’t ever get 4g. Since upgrading, SIM1 only gets 3g (as shown in the top bar), whereas I used to get “H” (4G) most of the time. I’m in the same places as before, same SIM etc. I think the use of 3g rather than 4g is contributing to fast battery drains (battery life notably reduced).

1 Like

“H” should be the indicator for HSPA, and that is still 3G.


Under Android 5.1 I got 3G below E iirc, i.e 3G would have been GPRS, E was Edge UMTS/HSPA was H or H+.
I don’t have LTE, so I don’t know how that looked like in 5.1.

Now with Android 6 I can confirm that 3G is HSPA. I don’t know if this is a flaw or if this works as designed in MM.
Again, can’t tell what 4G/LTE should look like.

Android 6 seems to show only three* different mobile network states in the status bar:

  • E: EDGE (2G)
  • 3G: anything from UMTS to HSPA+
  • 4G: LTE

While you’re on 3G, you can go to Settings / About phone / Status / SIM status for details.

(* Well, GPRS probably also still exists, but I haven’t seen that in a long time.)


Thanks folks! I had my letters mixed up :slight_smile:

Still, the letters I used to get on Android 5.x I no longer get in Android6, and from ChuckMorris that sounds like it’s a ‘feature’ of Android6, rather than a problem on my phone.

(which is OK, but leaves me wondering why battery drain is high again - I’d thought it might be that the data connection was struggling in some way, maybe only using slower/more energy intensive links).

For those of you who still can’t switch which SIM has the 3G/4G connection, this post might help:

It seems that the topic linked above is a later duplicate of this one. I suggest to continue the discussion there if there are any further questions - I’ve set this topic to close soon, but let me know if I misunderstood that the issues described here are the same as those in the linked topic.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.