DNS not working on mobile Data, after update after beeing rooted

I’ve rooted my phone after I got it so I can transfer both my apps and their data to my new phone, which worked perfectly. After I was done transfering the data I updated my phone to the latest version which removed the root access.
Howerever now whenever I try to connect via cellular data the phone is unable to resolve dns adresses, (pinging 1.1.1.1 works finem, but I can’t ping google.com or access websites, and I get internet trough mobile data when I use somthing like the 1.1.1.1 app to force the use of that dns sever). I assume that somthing I did while rooted (maybe the use dns over https setting I enabled in the magisk app) changed some dns related setting for mobile data which then didn’t change back after root was removed when I updated.
Is there any way to fix or check this without rerooting the phone or resetting everything (I rather not spend another day setuping all my apps again)? Anything else that could have caused this problem/anything else I can try? I guess it could also be a problem with vodafones dns servers.

Right now I’m unable to re root my phone becouse I’m on the latest version (A.149.20220722) and the boot.img file that I need to patch to root for that version is not availible yet on (Fairphone 4 Kernel Source Code — FAIRPHONE open source documentation)

Were you able to solve this already or is the problem still there?

As far as I can tell that setting only applies to the Magisk app (it’s in the App section), not system-wide.

Since this involves mobile connectivity, have you tried resetting your APN(s) to default?
Settings → Network and Internet → SIMs → [Name of provider] → Access point names → → Reset to default (Might be slightly different under stock FPOS)
Probably unrelated, but always a great start :slightly_smiling_face:

Also have a look at what’s set for Settings → Network and Internet → Private DNS

Oh, your provider is Vodafone :see_no_evil:
Well, there have been a lot of problems with them in the past, for example with the previous update

The Problems still there, resetting the APN to default didn’t help either. Private DNS is set to off in settings, but changing it to automatic or entering the hostname for cloudflares dns services also dosn’t work and dosn’t solve the problem. The workaround using the 1.1.1.1 app or a vpn works but isn’t really ideal.
Is there a way at least find out what dns it’s trying to use without rooting again? I guess there’s no good way to fix this without rooting and changing the DNS settings, or hoping that an update/vodafone will fix whatever the issue is.

Maybe I’m having the same issues people also mention about the update as the problem first started after updating to A.142 (I’m now on the latest A.149 version whitch didn’t fix the problem), did anyone else who has that problem check if they can still ping 1.1.1.1/if using a VPN/dns changer app like the 1.1.1.1 fix the problem for them?

Edit I tried again after right after posting this reply and it seems to be working now (It didn’t work 5 minutes ago when I was posting this reply).

Alright then, maybe it just took a moment for the cache to update after resetting the APN or your problem is completely unrelated :man_shrugging:

Let’s skip the debugging deep dive for now (until it starts acting up again) :smirk: