Device won't unlock for installation of /e/

I tried to install /e/ on my new FF3 and did really everything the descriptions on the FF-website ( and the lineage-os site ( tell me.
I managed to link the FF3 to my Win7 PC. adb devices finds the FF.
Hovever, when I do fastboot, the phone says “Device State - locked”. Of course, I’m in developer mode and OEM unlocking is toggled to ON. So everything seems to be ok there. Surprisingly, if I’m doing fastboot devices, I don’t get anything (while at the same time adb devices lists the FF3).
What else can I do to get that phone into the unlocked mode?

Welcome to the community forum.

Please thoroughly follow section “3. Unlock your bootloader” on the support page you linked to yourself.

Please thoroughly follow section “3. Unlock your bootloader”

… which is exactly, what I did, but it won’t work. In the terminal window, fastboot devices doesn’t even FIND the phone, while adb does.
Maybe it has to do with the PC-driver. In the hardware manager I can see an Android device, but with an exclamation mark that says “driver is not installed”. Plugging off the phone, deleting the driver and plugging in the phone doesn’t help, either. I got the driver exactly from the quoted google-site.
Upon “fastboot oem unlock” the terminal window locks with the message “waiting for any device”

Entering fastboot devices outputs No devices found or something similar?

… it doesn’t yield ANYTHING. It simply returns to the command line.

By the way: The PC has now found the driver of the Android Device! It says “Google Nexus ADB Interface”, but that still doesn’t solve my problem.

Ok… either I’m stupid, or I don’t understand. Could you send a screenshot of your command line?


Ok. Are you in fastboot mode on your phone?
If it doesn’t display anything, it means it doesn’t recognize your phone.

1 Like

You are right: The screenshot was NOT in fastboot mode, BUT:
If I restart the FF3 in fastboot mode, ADB no longer recognizes the device, and in the hardware manager on the PC I once again have the exclamation mark.


ADB doesn’t work in Fastboot Mode, so far so normal.
fastboot not working is odd.


Thanks for your efforts. I’ll try this tomorrow and keep you informed.

ok, folks, I tried this suggestion and was already surprised at step 2:
In Control Panel, Progs and Features there was NO Android SDK! ADB and Fastboot were not installed at all (well, because according to the FF3 instructions it only said unpack the downloaded archive in some folder; unpacking is not an “installation”).
I don’t have Win10, I have Win7 by the way, but that shouldn’t really matter.
In device mgr there was NO ADB, MTP or whatsoever smartphone device (FF3 wasn’t connected to the PC).
After reboot I plugged in the FF3, started in in fastboot mode and everything was the same as before. NO drivers were installed automatically, and when I tried to install this universal driver Win7 complained that there was no driver for the device.
To me it appears that the PC recognises the FF3, when in normal mode, but never when in fastboot mode (e.g. “adb reboot bootloader” yields “no devices/emulators found”).

Ok, I am an Win10 and I have ADB installed.
Take a look here:

Ok, friends, I GOT the solution now!
The USB-driver was missing. For some reason, it did not work with this universal USB-driver. Find a detailed description of exactly my problem and solution here:

This is the instruction I needed:

ADB and fastboot require different USB drivers.

Whilst you may see your device under adb when your phone is on it will not be detected by fastboot until you install the driver for it and hence will show “waiting for device”.

You can follow the steps below to do so:

  1. Open your device manager and reboot your device into fast boot by pressing volume up, down and power button simultaneously
  2. You will notice that device manager refreshes and now your phone has a yellow icon
  3. Download the Google USB driver, it is a zip file so go ahead and unzip it in your local directory
  4. Right click on the yellow triangle for your device and update driver, select the option update from local storage and select the folder “usb_driver” under extracted files in previous step
  5. You are good to go now, fastboot oem unlock will detect the device now

The Google USB-driver worked and immediately fastboot devices recognised the FF3!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.