Default launcher lost after reboot

Hi,
I use Niagara launcher.
It’s the launcher selected in “my default apps”.
On every reboot, i’m (re)asked about the launcher to use : QuickStep or Niagara.
Even if i (re)select Niagara and “always” i’ll have the question on the next reboot…
Thanks.

Have you tried another launcher, for example ‘nova’ to see if it is any different?

never had any problems with any launcher, but don’t know niagara…never heard

Maybe this is caused by Niagara needing Quickstep for Recent Apps support :thinking:
From their support article:

Gesture navigation and Android’s recent apps screen are always controlled by a submodule of the preinstalled launcher, not by third-party launchers (like Niagara Launcher). As a result, they may behave differently in combination with third-party launchers than with your preinstalled launcher because two apps are responsible for the home screen and navigation.

Sadly Niagara doesn’t support QuickSwitch, according to their docs

Does Niagara Launcher support Quick Switch?

Unfortunately not. Niagara Launcher isn’t based on Launcher3 (the reference Launcher implementation in Android).

…so it will always need Quickstep.

In any case, this sounds like an issue for their issue tracker.

2 Likes

I have the same Problem with Nova Launcher

Welcome to the community :wave:

Since there haven’t been any updates on this issue I’m not sure if someone can help you here, have you tried Nova Launchers Discord Channel or contacting their support? :thinking:

Hello, I am also a NiagaraLauncher user (since 7-8 months) in a FP3+/Android 10 and don’t have such problems. Niagara ist listed as a standard App, even in the configuration Menu inside




the launcher App.(see screenshots)

I am using Nova Launcher as well currently and do not face this problem. I rebooted my phone just now to be sure and this didn’t happen. Nova Launcher still remains as the default launcher after reboot.

Thanks a lot :slight_smile: I will reset the settings and try again :slight_smile: