December update won't download/install

I have trouble installing the December update. Here’s what’s happening:

I started downloading the update a few days ago and paused the download about 20% in. A day later I resumed and paused again after maybe another 5% progress. Since then, whenever I try to resume the download it starts, then pauses on its own after no more than a second, then resumes again, then pauses again, and so on. This keeps happening until I tap Pause. The ~25% progress is visible on the download bar, but no new progress is being made whatsoever.

I read about wiping the cache partition in order to restart the download, but I could not find a way to do that on the FP3.

I then tried to update via adb from the recovery screen. I used this download link from the forum. After starting the sideload, the upload on the PC counts up towards ~47% and then stops with the message Total xfer: 1.00x (which seems to mean the upload is complete, I guess?). On the Fairphone I get the following output:

Finding update package...
Opening update package...
Verifying update package...
Update package verification took 7.5 s (result 0)
Installing update...
E: Error in /sideload/package.zip (Status 1)

I can’t try to update via sdcard because I don’t have one. I did not have any issues with previous OS updates.

Is there anything else I can try?

Have you tried a soft reboot, like described in

manually reboot it by pressing the power button for 15 seconds or by taking the battery out.

You could also try emptying your cache using Google’s Files application, as described in

Good luck!

Thanks for your ideas.

I was able to reboot before without it fixing the broken update, and neither of the article’s suggestions on rebooting changed anything about that.

I installed the Files by Google app and cleared all the app caches as described in the linked article. Still no change. The download keeps resuming, pausing, and resuming again. The progress meter is still about a quarter full.

Does anyone know where the partial download actually resides? I can’t access the cache partition to check, nor can I wipe it. At least I don’t know how; the recovery menu has the option removed.