🇩🇪 🇬🇧 Amaze 3.1.1 crashes (preinstalled with FP OS 1.10+)

Bei jeder Aktion, die Amaze verlässt (File öffnen oder auch nur zurück zum Homescreen), stürzt Amaze (v 3.1.1) mit Fairphone Open 16.11.0 verlässlich ab. Kann ich dagegen etwas tun?

1 Like

Eventuell mal unter Einstellungen > Apps bei Amaze die Daten und den Cache löschen. Ich habe auch FP Open 16.11 und die gleiche Amaze-Version & bei mir funktioniert die App tadellos.

Nachdem das kein generelles Problem zu sein scheint, habe ich deinen post in #fairphone2help verschoben.

Das kenne ich. Die Lösung für mich war: Rückaktualisierung von Amaze 3.1.1 auf die Orginalversion3.0.1.


Ah, danke, das werde ich versuchen. – Ja, sieht gut aus. Danke!

Habe Amaze auch rückwärts :grinning: aktualisieren müssen. Die alte Version läuft hier stabil, die neue zickt nur herum, häufige Abstürze und Performance-Schwächen.

Also doch keine einmalige Erscheinung …

I moved this back to #software since it turns out to be a widespread issue with Amaze 3.1.1.

:gb: To everybody who doesn’t understand german: Downgrade to Version 3.0.1 and everything will be fine again.

When I tried to downgrade via F-Droid I got an unknown error but then I tried to uninstall via F-Droid and got a prompt “do you want to replace this app with the factory version?” which is exactly what you’ll want.


It’s an issue with FP Open then, I don’t experience any crashes on my FP1.

Also my Amaze 3.1.1 is crashing regularly after every action on my FP2 (OS 1.8.1)…

I have the same problem: Amaze has been crashing immediately every time I start it for some time on my FP2 (Fairphone Open). Just now, after I installed the last OS update, I downgraded to version 3.0.1 (through Settings - Apps - “Uninstall updates”). It crashed again after a few seconds. I went back and cleared the data - it crashed again, just as fast (“Unfortunately, Amaze has stopped”.) Any other ideas? I thought of uninstalling and reinstalling the app but there is no “Uninstall” button for Amaze in Settings. I tried through F-Droid and got an error message (“Error uninstalling %s ; Failed to uninstall due to an unknown error”)

Wenn Du einAmaze mit Update hast, dann findest Du in der Appverwaltung bei Amaze den Punkt “Updates deinstallieren” (da, wo sonst auch gern “deaktivieren steht”). Deinstallier das Update und Du hast die Werksversion, die nicht abstürzt.

Danke - aber leider hat es nicht funktioniert. Ich habe den Update deinstalliert und bin zurück auf Version 3.0.1. Es stürzt mir weiterhin ab.

With the Update 1.10.1 of FairphoneOS, Fairphone introduces a new version of the file manager Amaze. This Version 3.1.1 has always been broken, sadly, and I could not downgrade Amaze to Version 3.0.1.
The problem, however, is that Amaze 3.1.1 will create bad copies when copying files that are not very small. Just copy a big file from your internal storage to an external SD card and let Amaze calculate the MD5 checksum of the original file and of the copy. (This can be achieved by opening the properties of the file and wait a little.) Other copying than internal => external may be affected, too. I had that Problem when updating Amaze on earlier FPOS releases using F-Droid. I had to downgrade again. I had that bug back after updating FPOS to version 1.10.1.
Here is what I tried to downgrade Amaze again, but die not work. Download the earlier Amaze Version and install it. You find it on F-Droid’s site: https://f-droid.org/repo/com.amaze.filemanager_29.apk
Also downgrading within F-Droid App die not work. Uninstall via settings->Apps is not possible.
Greatings, let’s find a solution…

I just stumbled upon your message. Thanks for mentioning it.

I do not know of a way to downgrade an app over the user interface. However, it can be done with adb (Android Debug Bridge).

First I get the file on my Fairphone 2. I do this by pushing it with adb, but you can also directly download it with the phone, in that case you need to change paths.

adb push ~/Downloads/com.amaze.filemanager_29.apk /sdcard/

Now, everything is in place to use pm to downgrade the version.

adb shell pm install -d -r /sdcard/com.amaze.filemanager_29.apk

The -d option forces downgrades and the -r option allows replacing of an already installed package. /sdcard/com.amaze.filemanager_29.apk is the location of the file on my phone. Change this path to where you have stored the file on your phone.

We will try to fix this in the next release. Do you know which is the current stable version that does not suffer from that bug?

On a related note: Is this bug known to the devs of Amaze? If not, can you please report the issue there? This is the best way to go because (a) it solves the problem for all users of Amaze and (b) it solves the update issue since a newer version can easily be installed over the broken version.


The two posts above were moved here and the topic renamed to reflect the fact that Amaze 3.1.1 comes preinstalled with the latest OS update.

@jftr: The latest stable version of Amaze is 3.0.1, but as you can read in posts above some people still have crashes after they downgrade.

I you did an update of the system and this update comes with a new version of Amaze, then this version of Amaze is a system-app and can not be downgraded in the normal way nor deinstalled. You have to use adb.

So if you need a working version of Amaze decline the update and wait till the Fairphone-developers make their homework.

Auf deutsch: Wenn Ihr eine funktionierende Version von Amaze braucht, dann vergesst das Update auf 1.10.1 …

1 Like

I tried to reproduce the issue with my phone (Amaze 3.1.1, FPOS 1.10.1, rooted), but it doesn’t crash. I opened some arbitrary files and it worked well. Maybe it’s due to root? I have the root-option enabled inside Amaze. :wink:

Do the crashes happen only on FP Open?

No, @therob (on FP OS 1.8.1) was reporting crashes of Amaze 3.1.1 too. See above.