DCIM directory on SDcard got empty and blocked after integration process

Never change a running system, I know. But sometimes there is no way out and so I decided to add a SANDISK 128 GB microSD-card. Moreover, I decided to let Android 10 to format it and move data from the internal to external memory. The process was carried out smoothly. When I took a picture today, I was puzzled since it wasn´t stored:
The DCIM directory on the SDcard is empty! Media data stored in DCIM haven´t been transfered to the SDcard. But what´s even worse:
The DCIM directory is blocked! Nothing can be copied to it and even a subfolder can´t be created.
As for my “open camera”-app I found a bypass by creating a subfolder under “pictures” which was exported successfully.
But the internal camera app is now out of order since it doesn´t allow to change the storage location. It is set by default to “telephone”:
grafik
Does anybody have an idea why Android10 blocks DCIM and how this lockout can be removed?

1 Like

There are two ways to set up an SD card, and from the symptoms you describe, you most likely chose the “wrong” one – If you choose to format the SD card as part of the internal memory, there are all kinds of bugs coming with this currently (until developers can fix it).

If you upload a screenshot of Settings > Storage, we can see right away if that is the case.

4 Likes

grafik

Well, honestly, I heard about these issues some years ago but I supposed them to belong to the past. I didn´t expect that they affect still the latest smartphone technology (FP3/4, Androis 10+).

Thank you for your link. So I understand, I have to make a u-turn and to turn the external storage in a mobile one, haven´t I?

Afterwards one is always wiser. :roll_eyes:

3 Likes

Yes, for the time being this is the status quo (I think the issue arose with the upgrade from Android 9 to Android 10 on the FP3 and FP3+). Murena even removed altogether (for new installtions) the whole option of formatting the card as internal from /e/OS until the bug is solved.

5 Likes

I see. Well, I fixed the issue finally by following your advice: The attached storage is now a mobile one. Have a nice weekend. :slightly_smiling_face:

2 Likes