DAV (cardDAV & calDAV) setting on FP1

Hi all,
I used to sync addresses and calendars between my computer and my FP1U with a old version of ownCloud (on a cheap and shared hosting) and DAVdroid 0.8;X and everything was right. Good old time…

I had to check a newer version of a cloud for a little npo so I installed nextCloud 14 and I upgraded DAVdroid to 1.3.8 and now it a nightmare. DAVdroid can contact the server, get the list of calendars, it can create accounts for cardDAV. But there is no data exchange. The calendar app and addressbook app are empty. When I create a new contact on the phone, it disappears on syncing. The new events are not sends…

Does somebody knows a solution to debug this situation ? A place to get more information ? A way to get information ?

Self-hosting can be really challenging. I tried it at the beginning, but soon moved to posteo.de as a cloud for calendars and contacts.

You could try to remove all data (wipe data in the app details - settings > apps > DavDroid) and accounts and add them again. If this doesn’t work I suspect an issue with Nextcloud.


I use my own Nextcloud instance and exchange data with CalDAV-Sync and CardDAV-Sync on one FP2 and with DAVdroid 2.0.4-ose (F-Droid) on another, after your message. Worked out easily and instantly for me - maybe I can help you with your questions.

1 Like

Please check if the last update of DAVdroid on F-Droid is possible on a FP1 with android 4.2 ?

It wasn’t easy to find out. Latest Davdroid 2.0.4 requires Android 4.4:

It seems Davdroid 1.3.8 might be the latest available version for Android Jelly Bean? Maybe Nextcloud doesn’t work together with it anymore. @FrViPofm You can install Android Kitkat 4.4. #macadamia (click for instructions).

OK… Thanks for your answers.

*The problem is not from the NextCloud server that work well in web mode, and in sync mode (both CalDAV and CardDAV) with Thunderbird. I get very good syncs of notes with “FolderSync” app. But I get the same problem of Card/CalDAV with other instances of nextCloud ( e.g. Framagenda )
On F-droid versions, it seems that Android 4.4 is required from DAVdroid 1.9.3. So I’ve tried several.

@Amber FP2 is not under android 4.2 and I can’t use the latest version of DAVdroid. Even the DAVdroid 1.3.8, that is supposed to run on my phone doesn’t work.

I have tried :

  • aCalDAV 0.1.1
  • DAVdroid 1.9.2-ose
  • DAVdroid 1.7.3-ose
  • DAVdroid 1.3.8-ose
  • openSync
  • CardDAV-Sync 0.4.21

Sometimes, it seems that the link is established. Sometimes, I cans see accounts in DAVdroid (or others). Sometimes, it seems that data are recieved (long time of synchronization of calendars). But never I can get cards in the “Contacts” app (v° 4.2.2-2015081400), events in the “Agenda” app (v° 4.2.2-2015081400), or tasks in OpenTask app (v° 1.1.13). Sometimes I can create an event or a card in an empty addressbook or calendar created. But never I can send it to the server and see it on the web GUI on in Thunderbird.

If your time permits, you could install FP1: Macadamia 1.9.9-pre3 Alpha (Android Kitkat). DavDroid 2.0.5 from F-Droid works just fine here. :slight_smile:

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.