🇳🇱 Dataverbinding niet stabiel

Mijn FP2 heeft moeite met contact voor dataverkeer, zowel gsm als WiFi maar het probleem verschilt voor beide gevallen.

  • GSM-data: de boodschap ‘Geen internetverbinding’ terwijl Android aangeeft dat die er wél zou moeten zijn. Het enige dat helpt is een reset (soms 2x).
  • De WiFi verbinding wordt heel vaak (elke paar minuten) kort onderbroken. Voor somige functies heb ik er niet zo’n last van, maar voor functies die communicatie met een andere app of apparaat in mijn thuisnetwerk vereisen (bijv. een ChromeCast) is het fnuikend.

Ik heb nog een nieuwe ‘top module’ en een FP2 die in onbruik raakte vanwege falende ‘bottom module’ en véél te vaak een spontane reset, dus ik vraag me nu af of ik daamee mijn FP2 kan helpen.
Weet iemand ergens een lijstje of tekening van de functies van de diverse modules van mijn FP2? Of misschien een lijst van problemen en de module die evt. vervangen moet worden?
Hartelijk dank!
Mabel

Ik heb twijfels dat een nieuwe top module je FP2 kan helpen als je verbindingsproblemen hebt. De antennas zijn naast het core module.
Als je het over GSM hebt: Welke RAT (radio access techology) gebruikt de telefoon? Edge (2G), UMTS (3G) of LTE (4G)? Als hij niet boven Edge komt, dan is de verbinding vaak niet snel genoeg en apps zeggen dus vaak dat dit geen (goede) verbinding is. Dit kan gebeuren als het voor deze sim kaart verkeerd ingesteld is of als de verbinding inderdaad slecht is.
Voor de Wifi problemen: Kijk maar eens of dit gelijk is aan jouw situatie: ✏ FP2: Solving Wi-Fi connectivity problems with 5 GHz networks

Succes!
Martin

@Martin_Anderseck Hartelijk dank voor je reactie. De voorkeursinstelling voor gsm is LTE en meestal geeft de display aan dat die in gebruik is. Je had het over antennes, maar wat ik verdacht vind: na een of meer keer uit en weer aanzetten (NIET ‘herstarten’!) doet hij het wél!
Betr. WiFi: dat is inderdaad een mogelijkheid, dat’ie omschakelt tussen 2.4 en 5Ghz. Goeie tip! Ik zal het meteen proberen.
mabel

Hoe oud is je sim-kaart? Wellicht doet je telefoon het beter op een nieuwe sim-kaart. De Fairphone is gevoelig wat dat betreft.

Zie je aan de bovenkant van de scherm dat hij 4G gebruikt of zie je dat alleen als je van boven met de vinger de scherm in trekt? Soms heb ik deze bug nog wel dat er geen data verbinding geopend wordt terwijl hij dat eigenlijk zou kunnen doen. Dan zie je in de lijst boven maar het driehoekje maar niet 4G daarnaast. Dat zou passen bij wat je beschrijft. Dan helpt inderdaad maar herstarten of van de telefoon of via de flight mode.

@Lidwien Mijn simkaart is pas ruim een jaar oud, dus daaraan zal het niet liggen. Evenzogoed bedankt voor de tip dat de FP hier gevoelig voor is (mijn partner heeft er ook een met een veel oudere simkaart).
@Martin_Anderseck Als ik van bovenaf swipe zie ik o.m. een button voor de dataverbinding; die is groen als er verbinding is (of zou moeten zijn) en daaronder staat dan LTE. Ik tik erop en de data-verbinding wordt verbroken; weerom tikken en hij wordt hersteld. Maar dit blijkt nooit genoeg om de verbinding ook daadwerkelijk te herstellen; dat lukt me alleen met totale reset (en dus zelfs niet met ‘herstarten’ maar alleen met uit en weer aan zetten).
Mabel

Als je geen verbinding hebt, zie je dan 4G boven in de lijst, zoals hier?


Als er alleen maar het driehoekje van de signaalsterkte is, maar geen 4G daarnaast staat, dan is het een bug die tenminste voor mij nauwelijks meer voorkomt en eigenlijk gefixt zou zijn voor de meeste gevallen. Je zou dus kunnen kijken of je de laatste updates geïnstalleerd hebt.

@Martin_Anderseck Dank dat je me wees op het symbooltje bovwenaan; ik had er nog niet zo op gelet maar het lijkt er inderdaad op dat de aanduiding 4G (in mijn geval LTE) bovenaan ontbreekt als er geen verbinding is. Als ik omlaag swipe zie ik:

Ik zie dit ook als er geen verbinding is en dit scherm geeft dus kennelijk alleen een instelling weer en niet een stand van zaken.
De vraag blijft natuurlijk waaróm er regelmatig geen verbinding is (hardware probleem?) en of ik daar iets aan kan doen.

Je tip over de WiFi lijkt prima te helpen.
Mabel

1 Like

Wie heb je als provider? En wat zijn je APN instellingen van de Simkaart?

Toen er dit soort problemen op Lineage OS was, was het de Modemmanager, een stukje software dat verantwoordelijk is voor het aanmaken van de dataverbinding op het LTE modem, die gecrasht was en niet weer naar boven kwam. Fairphone OS heeft dit probleem ook gehad, daarom de vraag of je de laatste versie geïnstalleerd hebt. Anders kan je weinig aan de software doen, maar even naar de APN instellingen kijken doet geen kwaad.

@Lidwien De provider is Ben. Maar ik denk niet dat daar het probleem zit want de ‘zuster-telefoon’ (tegelijk gekocht; nu buiten bedrijf wegens andere gebreken) heeft dit probleem niet, met dezelfde simkaart. Vandaar ook mijn oorspronkelijke vraag of ik iets aan die tel. zou hebben om van het probleem af te komen.
Wél één dingetje gevonden in de instellingen: het ‘verificatietype’ stond niet ingesteld (moet PAP zijn volgens ben.nl). Zal het helpen?
@Martin_Anderseck Versie is 23.02.0-rel.0. Bij mijn weten de laatste, toch?
Mabel

Dik kans dat de verandering in verificatietype de oplossing is. Ik hoop het zo voor je.