Data Roaming when at home

I’ve never had this issue before, my phone claims to be roaming when I’m at home (I don’t know why). I’ve done the tutorial and there is no option to turn data roaming off. My data connection option is set as off. How and why is this happening and how do I go back to my normal network? Also will leaving it on airplane mode for the time being stop me from incurring costs

Yes, airplane mode will switch off all mobile traffic, so it’s a guarantee against extra costs. On the other hand your phone becomes pretty much unusable (you can of course connect to a WLAN with the phone in airplane mode).

But you can disable data roaming:
System settings > Wireless & networks - SIM management > Roaming > Data roaming > untick the box to the right of your provider’s name

Another way that should prevent roaming is to set your network operator manually:
System settings > Wireless & networks - More > Mobile networks > Network operators > Choose manually.

Not sure why this has happened to you, but two possible explanations come to mind:
a) you live close to a national border, and the signal from abroad is stronger than the signal from your domestic provider, or
b) The same network is shared by more than one operator, often a subsidiary - a so-called virtual mobile network operator. This can cause a false roaming indication. The FP OS takes care of most of these, hiding the roaming indication, but maybe there are (new) VMNOs that hasn’t been listed. In this case the roaming indication is false and nothing to worry about.


Thanks so much for your thorough and insightful reply. I’ve done all of the above, however there is still an R appearing and it says ‘there is no local sim…’. I’m aware that this could be a problem with the sim (although it worked fine in my last phone), but I’m still concerned that it’s appearing as roaming despite switching off all roaming settings.

And no I live nowhere near the border, so this is most odd. I will phone fairphone on another phone tomorrow if this persists.

My guess is that it’s a MVNO issue, i.e. a false roaming indication.What operator do you have, and where do you live?
In the UK, for instance, there are almost 30 operators (among them Asda, Sainsbury’s, Virgin and Co-Op) that all use the EE (physical) network. It might well be that the FP OS hasn’t taken all of them into account (in that case it will probably be solved in a later OS update).
And I’m pretty sure that it isn’t possible to roam on another national network (except for emergency calls, of course). So I really don’t think you need to worry. I lived with the ‘R’ indicator myself for some months (due to an unrecognised MVNO) until a FP OS update solved the problem.


Ah this rings a bell, I’m in Scotland currently and am with Virgin. I will contact them. Thanks once again for your help. I’ll ask them if I should use it in the meanwhile.

1 Like

I wrote a little tutorial a while back. Does it work for you? I’m eager to hear other experiences:

1 Like

Sainsbury’s use the Vodafone network, not EE

I’m on Mobile by Sainsbury’s and have never seen the roaming symbol in the UK. I do however have a minor issue that going from wifi to 3G data often doesn’t work until I switch the 3G off and on again or similar.

it could be you have a “Dual IMSI”, it’s something some operators use to offer roaming when traveling without having to test all operators.
I would not be surprise Virgin use this system.
Your SIM has two identifiers:

  • the one of Virgin, to be used when you are in the UK
  • the one of another mobile operator, to use when you are abroad.
    Your phone should automatically switch to the local identifier when you are in the UK, but it seems its not the case, try do it manually:
    look into your “SIM menu” there should something called “roaming” and change the settings from there.
    I cannot be more precise because it depends on your operator, how they have done the menu.
1 Like

I’ve been having the same problem lately, but I am indeed in Germany very close to the French border. In the past, there was a certain part of my town that I would lose signal in. But in the past week or so, it sometimes switches me to roaming even in my house. It was never this sensitive before.

Hi everyone,
I have encountered the same problem after I returned from a trip abroad. When back in Germany, my phone showed the little R, even when at home in my network.
What helped was just to click the “Select network automatically” button under WiFi & Networks.
Now it is gone.


Hi everyone,

my Fairphone went on roaming mode today while being logged in to my home network (o2), too. I stayed abroad until two weeks ago. After that I was in Hamburg, where everything worked normal. I returned to Tübingen in southern Germany yesterday night and today discovered my phone thinking it was abroad.

I’m not so sure if o2 Germany is a MVNE Operator and I am not close to any border here.

OK for o2 and E-Plus in Germany, this is the reason:

O2 and E-Plus are sharing their networks in some kind of national roaming thing. I hope this doesn’t my phone will keep asking me about whether I’d like to continue every time I make a call now forewer…

1 Like

I just wrote a post on this:

It is a wiki post, so you can even improve it yourself.


Yeesh. Well, thanks for the info!

Is there not some way to force the phone to stay on a single network? I actually do live near the French border and before this it was always the case that my phone would switch to a French network on the way to work each day (which was confirmed each time with a text from o2 explaining costs). So I’m hesitant to just ignore it and data-roam myself into a large bill.

Please try this tutorial I wrote a while back and report if it works for you:

1 Like

Nope, still experiencing the problem despite entering the 3 PLMNs for “O2 DE” listed here.

What if you delete the other PLMNs (especially the ones from French networks)?

Hmm, tapping an entry, tapping menu, and then tapping “Delete” does not actually delete it from the list. Is there some other way to do it?

Are you sure? :frowning: It works for me… Restart the phone and try again, please.

1 Like