Data not working - UK Fairphone 2, TPO

I have had no luck getting data to work here in the UK. My provider TPO has twice given me the APN settings and says therefore it must be the handset, but I can’t figure out why.
The SIM was new and works for calls and messages.
Help gratefully received because I’m stumped. Thanks!

Have you tried entering the settings manually or are they sending them to you OTA?

Hi Jon

Yes I’ve entered the settings manually twice.

Have you tried setting the network mode for the TPO sim to 2G+3G (i.e. not 4G)?

Hi Johannes, I haven’t tried that, so I’ll give it a go now.

No sign of that working after a re-boot and waiting more than 30mins.

Can’t really think of anything other than the usual checks:

  • APN settings correct?
  • Correct APN settings profile active?
  • Mobile Data enabled (Settings > Data usage)?

Which you’ve probably done plenty of times by now. Hopefully somebody on the Forum who has a working a setup with TPO will comment…

1 Like

If you have more than one SIM, check if the right one is selected as preferred SIM for internet.

Thanks. I’ve tried all those things, and still nothing. I only have one SIM and it’s in slot 2 and it’s selected, slot 1 is turned off.

Did you already try to put in in slot 1?

I damaged the pins on slot 1 by accident trying to put a SIM adaptor in. So I’ve just been using slot 2, which works fine (for calls and messages). Does it make any difference which slot it is? As I say, I have slot 2 selected as preferred.

One thing I haven’t done is check the SIM in another phone. I’ll do that tonight.

@Irina_Spitznagel pointed out in another topic that there’s a German operator for which the SIM always appears to be roaming, which blocks the data connection. I’m assuming that you’d have noticed roaming notifications, but if there’s an ‘R’ next to the signal indicator, then that could also explain the issue.

Thanks for this suggestion Johannes but there’s no R so it doesn’t seem to be that.

One thing I’ve just noticed is that in settings>Network operators, it doesn’t seem to save my network operator choice. Even when I choose my operator (TPO) and then navigate away, when I come back it just says “Choose a network operator” again.

Is this the problem?

I think that’s the default behaviour (to only show it deeper in the menu). Given calls seem to be working for you, I wouldn’t suspect there to be a problem in network selection. Unfortunately these things can be tricky to troubleshoot. By the way, did you manage to test the SIM in another phone?

I went to test the SIM card in my old iPhone 5 forgetting it’s a different size SIM. I am thwarted at every turn!
So I could put it in my partner’s Nexus phone, but I then realised I’ll have to change his data settings to test it - so then I’ll need the settings from TPO for a Nexus etc etc. I guess I should do that, I was just losing the will…

The settings are the same for all phones afaik. Yeah, try using your partner’s phone

Hi Folks

So I’ve been away and got a new SIM card for my phone - on putting it in I have found that I still have no data. Messages and calls are still working. This tells me it is the handset that is the problem - not the operator, right?

In which case, can anyone take me back to basics and help me solve this?

Just did a web seach about TPO and their APN settings and it seems that you’re not the only one with this problem (have a look here). But to know if your FP2 is defective: Did you already try another SIM card in your phone?

Thanks for that link Irina, I’ll look into that now, and I’ll try another SIM in my phone tonight - that’s something I haven’t done yet