Cryptfs Password app error: "Cannot get superuser access, exiting"

Hey people,

finally I brought myself to encrypt my phone storage. Since I use the PIN to lock my phone the encryption is also locked via the PIN. To bypass this, I’ve installed “Cryptfs Password” from the F-Droid store.

Unfortunately it quits with the error “Cannot get superuser access, exiting”. I gave the app the superuser permissions in the settings of android but still it doesn’t work, even after multiple restarts. I deactivated XPrivacy controls completely for the app but still didn’t help.

Does anyone else also have this problem? If so, did you find a solution for this?

I’m on the newest OpenOS version 17.04.0.

Greetings!
Gökhan

Hey,

I did some research concerning this topic some time ago:

https://forum.fairphone.com/t/different-passwords-for-encryption-and-lock-screen/16885?source_topic_id=28998

As far as I remember, some of the solutions (as the one you tried) are only working when the phone is rooted with superSU, which is not available for the Fairphone. However, the app SnooperStopper works perfectly fine for me and in the meantime it’s also available on F-Droid.

I’m just curious: Does this also work for you on Android 6? I’m asking because since the upgrade I can’t manage to change the pw anymore; neither with snooperstopper nor from the terminal.

See:
https://forum.fairphone.com/t/fp2-fairphone-open-17-06-1-beta/29197/41?u=freibadschwimmer&source_topic_id=28998

Don’t know - I’m still on Lollipop. Haven’t tried to update yet due to the problems experienced by others…

@tphysm: Thanks for the recommendation!

@freibadschwimmer: Same for me here, changing the password does not work with either app. Did not try via terminal though. Kind of surprised that only few people seem to be interested in this topic.

I made an issue on GitHub regarding this problem.

2 Likes

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.