Connection problem with Google Maps

Hi there,

Since the last update of FP2 OS it seems that Google Maps can’t access to my Google user account properly.

Nothing happens when I choose “Connect to your Google account”. Therefore I can’t use functions like Home & Work address, trips history, offline maps (impossible to start downloading, it stucks ans says “connection impossible”).

Any hints ?

Thank you !


Try erasing the cache in settings > apps > all > google maps

Thanks Paul, already tried it but it didn’t work.

I don’t use Google so I can only guess, but one other thing you could try is go to Settings > Accounts and remove your Google Account. Maybe then you can add it again via the Google Maps app.

Well tried but the Google account is the only one that can’t be removed…

There must be a way to log out of the Google Account. Maybe in the Google Settings App?

Nope. The only way is to reset the phone to factory settings :-/

Go to settings
go to accounts
tab on Google
tab on your accountname
tab on the three dots right on top of your screen
choose ‘remove account’


Lidwien : thank you !

I didn’t figure this out, now everythings is working fine again :slight_smile:

Thanks everybody !


1 Like