Connected to Wifi but no internet connection


I cannot connect to the internet at my parents’ home. The FP2 shows me that I am connected to the internet, I can see the IP address and the MAC address and have a strong signal but it does not connect to any apps that require the internet. The security setting is WPA2 PSK.

When I try to connect the FP2 with the router by pressing the WPS button on the router the FP2 tells me that I am connected. But still nothing works.

I have played around with the 2,4 Ghz and the 5 GHz settings of the router and still no change. I have lower and security settings to no affect.

I suspect this being a setup issue as we had problems a few months ago with a Samsung 3 which couldnt connect either.

The router is a Speedport W921V from Deutsche Telekom.

Any suggestions?


Maybe it’s a DNS problem. Can you open Google web search by entering in the adress bar of your browser?

The Google site is not a good test - it redirects me to And this will not work when the DNS is broken.

@TobiasF and @Irina_Spitznagel I have tried the IP addresses you suggested. Using them in Chrome on my FP2 brings an error message saying - this can’t be reached.

Thanks for the clarification. Do you know a better adress to test it?

I mentioned it above with the Fairphone page. But it would appear without any images because they are linked by absolute address.

So your Fairphone can’t connect to the Internet or the Speedport at all - can any device connected to your Speedport access the Internet or the speedport.ip/ page? Are they connected wireless or with cable?

Is this actually a adress?

Yes. Other phones and laptops are connected to wifi and the internet.

The FP2 states that I am connected and next to the wifi indicator also shows small errors which I take as indicators that the phone tries to up/download something.

It is not a 192… address

I have checked the IP address as reported by the FP2 which is
The Speedport menu gives me following IP address

This is actually your public IP address as seen from the Internet.

According to the Speedport manual, this is not an address assigned by the Speedport. Did you enable DHCP for the network on your Fairphone? (Go to Edit Network [long press on Wi-Fi name], tick the Advanced Options checkbox and set IP settings to DHCP.)

Did you already remove this wifi from the list of know networks and tried to connect afterwards by entering the PSK key manually?

@TobiasF Sorry, I didn’t see your first post.

1 Like

Resetting the network settings on the Fairphone is still a good idea if my answer doesn’t work.

Your Speedport has to addresses: first the one to telkom, which is and a second one for a connected device, which should start with 192.168.x.x.

Check your Speedport for a page named “connected devices” or so. There you should see the IP of your FP2 and perhaps any warning. It could be that there is a checkbox “no new devices”?

For general checks of the connection
If you can reach a webpage by number but not by name, then there is a DNS-problem. If you can not reach a webpage even by number then you have a connection-problem between Speedport and FP2.


Yes, the setting is on DHCP, not on static.

Now try Irina’s answer.

Are you sure that there is no second DHCP server next to the Speedport installed (like a second router)?

I am not sure if I understand you. Here is what I have done.
I have ‘forgotten’ the wifi network already a few times and reconnected to the network. As it is protected I had to type in the network’s password. Not sure if this is the same as the PSK key. At the backside of the Speedport I an find the WPA2 key but I do not know if this is of any use and where on the FP2 I could type it in.

Try typing this key instead of the password.

I have typed in the long number. It now shows me an ‘authentication problem’.

Ok, then you should use the password… Could you please make a screenshot like this with your FP2 when connected to the wifi (tap on the wifi name):