Clock keeps running late

Hi,

The clock of my Fairphone 3 (not plus) keeps running late every now and then. Usually it was only 1 or 2 minutes, so I didn’t bother posting myself after not finding a fix. But today the clock is 6 Minutes late, which is unacceptable. (See Screenshot here: https://i.imgur.com/QKmtNec.jpg. Compare the time shown by the website with the time shown by the phone in the top left corner of the screen). The issue resolves itself from time to time, but I have yet to figure out how to reliably trigger this.

I am currently running Android 11, security update April 5th. Build number is “8901.4.A.0010 release keys” in case that’s relevant for troubleshooting.

The System is set to (System > Date & Time):
use network provided time: yes
use network provided timezone: yes

My impression is that the system does not regularly check the time on the network. Instead it relies too much on the built in clock to keep time, which in my case runs unusually slow. Is there a way to set the system to check the network time more frequently?

Regards Julian

Welcome our community forum. :+1:

I remember that in the past such problems sometimes occured as a result of a wrong network time. So in those cases, it wasn’t that that the system clock was slow, it was just “corrected” to a wrong time. Have you done a brief online search if this problem is reported currently by other customers of your network?

But if you want to test your own impression that the system clock is running late, you might want to just set the system settings you mentioned to “no” on both settings and test it for a day or so.

4 Likes

Hi and welcome to the forum.

I’ve always had my computers and phones set manually and the only problem is if i remove the battery then I have to reset the time.

My reasoning is that I don’t want my phone/computer calling out to some server whenever it is programmed to.

I agree. I also second (no pun intended :wink: ) Urs’s suggestion to let your phone’s clock run without correction for a few days. Drift shouldn’t exceed a few seconds per week.

@JulianK Which is your network operator?

2 Likes

Good point, I’ll try it out.
I feel stupid for not think of it myself and checking beforehand. Some research makes it obvious why there is no preprogrammed server: if the network can point you to a server you always get the local timzone as well.
My ISP is rather local, so I doubt I’ll find reports online. But very much possible they fucked up their network provided time.

I have the same problem since the Android 11 update. Today it was also 6 minutes behind.

I don’t think it is a problem with the network time being wrong. When I restart my phone it will have the correct time again. So I think it is an issue that my phone does not sync time regularly.

My last restart was about a week ago and it that time I was behind 6 minutes. Not great (especially when one needs to catch the bus).

Any other ideas how to fix this?

Hi and welcome to the forum.

Try setting the clock manually, I never use network time as ???

Hi oakentling and welcome to the FP community forum.

Have you tried disabling the automatic network time sync and letting the device run for a week without sync? I would not expect drift of more than a few seconds. I have just done this on my own phone (which does not have this problem) to get an idea, and will report back in a few days.

Even if you do not attribute this problem to the network, it would nonetheless be interesting to know the networks of users who encounter this problem.

1 Like

I will try that. I’ll try to report back in about a week. I’m curious as well if that will work better :slight_smile:

I disabled automatic network time sync on my FP3 on 7th July. Eight days later my phone is about 2.5 seconds behind network time. I’m going to leave it unsynced for the moment just out of interest, but I can repeat I’m seeing no problem.

I think this problem could be coming either from the network time of some carriers and / or from some software error that is trying to make a correction that doesn’t need to be made (could be related to time zones). When a system is trying to get a machine “back in sync” it does not usually just suddenly reset the machine’s time to the correct value. It will generally modify the time by increments, and the phenomena reported here look a bit like that.

Just a couple of ideas to check, if you are experiencing this problem:

  • Make sure the device and the network time are set to the same time zone.
  • Make sure the device and the network time are both implementing DST (daylight saving time) correctly. For example, could the phone be set manually to CET and the network to CEST?
1 Like

After the last 7 days without network time my clock does not seem to be off at all compared to an internet clock, i.e. both switch minute at the same time.
So I think I’ll keep it this way for the moment.

As for time zone settings, I think they should be the same on my device and the network as well as DST. I have no idea how to check what my provider uses. I’m living in a country with only one time zone, so it would be weird if they used something different.

For the time I will keep the manual setup. If I suddenly get such huge lag again, I’ll write again.

Thanks for ideas and help.

3 Likes