Choose provider manually

Seems to me that Fairphone ignores the setup to choose phone provider manual. I saw this these days. My Fairphone registered automatically to a foreign provider without asking me. And when you have data connection this could be a very expensive setup! To make it clear: The setup is clearly set to manual provider setup. I my opinion a very bad bug!


I’m not sure I understand what you are saying.

Data roaming is switched off by default, so you wouldn’t be charged any roaming data rates if your phone registers to a foreign provider - unless you have enabled data roaming. You can check this in Settings > SIM Management > Roaming > Data Roaming

Like all phones, your Fairphone will attempt to register you automatically with your provider, however if this is not available (i.e. because you are in another country) it will register you automatically to a roaming partner or other network - so this is working as expected.

If you mean you’re in your own country and it’s picking up a roaming signal, this might be a different issue, but if you could clarify what you mean I think that would be helpful.

I’m going to move the topic into the Fairphone Help! category for the time being.

In my country the Fairphone picks up a foreign provider and registers there - because the signal of my provider is very weak or is missing. If I have setup the phone to “manual” - there must be a question to the user if to switch. Right?


no, there is no setting for “voice roaming” in Android. So your phone is completely working as intended: Data Roaming is switched off by default, “voice roaming” is allowed.

If you are residing near the border of your country you will experience this behaviour regularly.

This app will help, maybe there is a free app out there I don’t know.



So the menu option manual or automatic provider setup is useless.


I think I found the setting you are talking about.

Seems to me that a roaming partner of your provider is not considered as a foreign provider.




I think the menu @tin means can be found like this: Enter “System Settings”, under “Wireless & networks” click on “More…”, there, click on “Mobile Networks” and there click on “Network operators” there you can then choose in between manually and automatically (at least on my Stock Android here).

And to my honest opinion, I think @tin is right: If you chose manual here the phone should never roam.

@stojmas That is nonsens, sorry. Phone should never switch to a foreign provider when setup is “manually”!

@sn0b - Thanks for your message. “Manually” should be not “automatically”.

Please move this thread back to “Bug Report”. Thank you.

I live near the border. Choosing my network provider manually works perfectly for me. After selecting my provider through this menu option, no other provider gets chosen.

I think we need to see whether anyone else in the community is experiencing this issue and whether there are any other suggestions that can be found to try and resolve this issue for you first before saying this is a bug.

Ultimately if you contacted support they would probably ask you to perform a hard reset to see if this resolves your problem.

Are you on the latest version of Fairphone OS (v1.6)?

@haffenloher - Of course: If you select a privider no other is chosen - hopefully this will work. But that was not my report.

@Chris_R - But “help” is wrong as well. And “hard reset” is not a solution - I really don’t want to loose all my date. And of course I have the recent OS version - what a question.

It seems I have also a problem like these mentioned above.
When my phone is not finding the net of the original provider, it is switching to data roaming to a partner provider and I’m paying a lot of money for a few kBytes. I cannot stop this. My OS is v1.6 and the box for data roaming is unchecked for both sim cards. The only way to work around this problem is to block the data completely and to switch it on only when the phone is registered in the right network where it is using the flatrate.

I forget to say : it is switching to a roaming partner in the same country, I’m not near the boarder …

Did you check your APN settings?

@Stefan : On first sight I cannot see something wrong with the APN. Everything also works fine with the dataconnection. The only problem is, that I cannot block the data roaming. When the phone cannot connect to the home network (in this case TRE.IT) then it connects to a partner network (TIM.IT) even when data roaming is deselected.
Anyway : For to have more security with the APN settings I will visit the providers office for to check with them.
If you have another idea - pls let me know about.

That’s the best idea, I think! Also confront them about the Roaming problem. Maybe they know the issue and can provide a specific solution.

@ Stefan : This morning I passed the office of my provider. The APN seems to be ok but they could remember another customer - also with a 2 sim smartphone - which had the same problem. They think that is is a problem of the phone and they cannot help me. Is it possible to contact the Fairphone ‘Bugs-department’ for to ask them whether there are other customers with this problem or not ?