Charging the FP2 / cable problems

Ok, yes, it is charging steadily. The red LED stays on, without flickering. And it hasn’t tried to automatically boot up anymore.

Thank you for all the help so far! Is it OK if I report what happens in an hour or so? I’ll leave it charging like this until it is fully charged. (Though, weird thing: the charging animation doesn’t show percentage. On my device, it tells me what % the battery is charged at at that moment. Now I just see the animation on the battery, but no %)

Please do so! I am very curious to see how it turns out. Sounds good so far!

The percentage and battery animation has slightly changed over the different software versions, I think in later ones the percentage has been forgotten, or simply removed. Btw: This could also be the reason why it charges in one device and not in the other, since some of the updates should have introduced improvements regarding sensibility to different chargers.

I’m now trying to charge her battery in my phone, but it’s unclear whether or not it’s working. The battery animation shows it’s at 74%, but it has not increased over the past 3-5 minutes. Also, when the animation disappears, I see no red LED or anything. Only when I first plugged it in, the LED irregularly flickered for about 5 seconds (as in: not a steady flicker, but LED for 1 sec, then 2 seconds nothing, then 2 flickers in rapid succession, then nothing, and then another flicker, and now no LED whatsoever)

Interesting observation.
It could be related to the charger: Have you earlier used the same charger without problems?
It could be th bottom module as well: If it isn’t properly connected (having a loose contact) to the mainboard, I would expect such a behavior as you described.

Ok, no, her battery in my device is not charging. In fact, it’s discharging even though the charging animation is being displayed. So I tried to boot up my device (with her battery in it), and now it’s “optimizing” my apps, which it also did when I tried putting her battery in my device earlier (and I completed the optimization then, so it’s weird that it has to optimize all over again, isn’t it?)

1 Like

Yes, the optimization is a sign that there could be a problem with the connection between modules, as I have read a couple of times that this happens after people changed modules.

In this case I would recommend again to try disassembling the bottom module, maybe cleaning the contact pins, and putting it together again. Hopefully this will solve the problem.

What software version do you have installed on your phone? (You can check that by going to All Apps --> Updater)


what are you using to charge ? A charger or the USB-port of a
PC/laptop/whatever (something which could also establish a data
connection) ?

With my FP2 I have seen this “rolling reset” behaviour, when trying to
charge on a PC/Laptop USB port. Fortunately it disappeared for me with
the latest firmware update 1.5.1. (Same cable, same laptop, same USB-port)



If you want to get the display of, you need (at least at the first time)
quite some pressure on the pushing. I only tried that, after one of the
videos clearly showed me the correct direction to get it of. (I had only
been curious, so I tried several times - at first all in vain)

Hey, me again, finally able to post another message.

So, the problem is still there. It still won’t charge.

I managed to disconnect the bottom module, but didn’t really know what to look for. I blew on it a bit, put it back together as neatly as possible. But … no luck. Still won’t charge.

Yesterday I had high hopes, for a bit. For the first time in three days, the little lightening bolt appeared on my screen when I connected the phone to the socket. So, I assumed it was charging. But when I checked the “Battery” settings, it explicitly said “not charging”. So, the phone was telling me both that it was charging and not charging, at the same time. I’ve not seen the lightening bolt since.

Right now, it"s again deep-discharged. When I plug it in, the red LED blinks a few times, then the booting screen appears, followed by the charging-battery-animation. This animation lasts for about 2 minutes, then it tries to automatically boot up again and the phone goes back to deep-discharged with red LED blinking.

I’m not sure what my options are here. Does it sound like I’ll have to buy a replacement for the bottom module? I’d prefer not to be buying spare parts on the hopes that it’ll fix it. It’d be a bad surprise if replacing the bottom module doesn’t fix the problem.

(Last note: I managed to update to 1.5.1. using the battery of a colleague, but it didn’t fix the problem)

What charger are you using? I didn’t see if you wrote that already in your previous posts…

The same charger I’ve been using for months now. A USB cable plugged into a 5V / 1.0A power supply.

Do you have a chance to try a stronger charger with 2A or more? Don’t know, but maybe your charger doesn’t deliver 1A anymore?

I can try. I went to a phone store yesterday and had them plug it into their charger, which didn’t work. The guy said that if it didn’t charge with their cable, it most likely wouldn’t charge with anything else. But I’ll try.

The weird thing about all of this is that the device somehow does recognize that it’s being plugged in, but it doesn’t charge. When I plug it in, the red LED starts blinking and the charging animation appears for a little while. So it’s not like the device’s USB-port doesn’t pick up a signal. It just can’t deliver the energy to the battery or something.

I did have a similar experience (red blinking, short boot logo) months ago. In my case the reason was cable/charger. Now all my chargers have at least 2A per USB port, no problems anymore.
But i’m not sure if it is the same for you, just my experience.
If the battery is deep discharged, maybe it will take some more time till the FP2 reacts, how long did you try to charge it in the store?

1 Like

I think we could try the following as a standard test kit:

  • Using an Apple charger from a friend with an usb port (they provide around 2.1 A most of the time and are of good quality)
  • Using an usb cable from a brand name company (Belkin …) or at least a cable that allows connecting to the device using adb (this shows that it is a real working usb cable)
  • Wait, charging takes time.
  • Kickstart your battery (I think this is also nonsense, but it’s been quoted so often … it wont’ hurt).

If this doesn’t charge your phone, something is broken and you should send it in.


Thanks for the reply.

I’ll try finding an Apple charger, or another charger with higher A.
Waiting does nothing. Last night I let my device plugged into the socket overnight, and still nothing. This morning I found it to still be stuck in a loop between deep-discharge and short boot.
I tried kickstarting the battery. I took out the battery, let it rest for more than an hour, then plugged in my phone without the battery in it, then waited about 10 minutes and then put in the battery. Nothing. No change in behavior. Also, when I connected the battery-less phone to the socket, it just kept on vibrating and booting every 1 or 2 seconds, nothing else. I managed to charge the battery in a colleague’s phone, so the battery is probably fine, I reckon. It must be something with the bottom module, or the little golden pins that connect with the battery?

1 Like

Also, I doubt it has anything to do with my cable not being able to bring a battery back from deep-discharge. I managed to charge the battery in my colleague’s phone, and even then I couldn’t charge it with my own device, regardless of which cable I used. :confused:

I’ll try to order a replacement bottom module. Hope that solves it.

I would let FP support decide on how to handle your problem. Else you might have to pay later for the module even if it wasn’t your fault that the module is faulty. Taking the FP2 apart and back together again might also help with the little golden pins.

Just use your friends module for testing :slight_smile:

  1. If it works, it’s the usb-module
  2. If it still doesn’t work, maybe the pins on the other side of your mainboard or your mainboard have a problem.

In the end … FP support or their sub-contractor will have to figure this out … and hopefully report back.

Hm, good idea about trying the bottom module from my friend. She’ll need a bit of convincing, since she was already quite skeptical about putting my ‘bad’ battery in her phone, thinking it might ‘break’ her phone as well. But I’ll give it a shot.

It’s a phone I got from my company, anyway. So if the module doesn’t work, it’s up to my IT-guy to have it fixed. I’m almost done trying to fix this mess on my own anyway.


1 Like

Ugh, it’s frustrating. The device is still connected to the socket, and every once in a while it actually manages to get beyond the booting screen. Just a few minutes ago it started “optimizing apps” for a bit, and it reached like 50 / 140. I saw the red LED blink slower while it was optimizing, then it started to blink irregularly, and then it went dark again. It’s like my phone is endlessly trying to reanimate itself.

Try starting the phone into recovery. Perhaps then there is more current available for the battery?