Changing bluetooth audio codec

My earbuds dont support LDAC, but aptX and aptX HD don’t seem to work for me either. AAC seems to work fine though, there is an option “HD Audio: AAC” in the settings for the bluetooth device which can be enabled and stays active even after reconnection.

Extract from an ‘adb logcat’:

 E a2dp_vendor_aptx_encoder: A2DP_VendorLoadEncoderAptx: 
    cannot open aptX encoder library 
    dlopen failed: library "" not found
E a2dp_vendor_aptx: init: cannot load the encoder
E a2dp_vendor_aptx_hd_encoder: A2DP_VendorLoadEncoderAptxHd: 
    cannot open aptX-HD encoder library 
    dlopen failed: library "" not found
E a2dp_vendor_aptx_hd: init: cannot load the encoder

It seems that the aptx libraries are not included for some reason. (Please note that I dont have any updates installed so far)

PS: No there is no pulseaudio on Android.

Yeah, I suppose it costs a vendor money to have those proprietary libraries shipped.

With an unlocker bootloader you could install that aptX package from XDA developers.

I’m having the same issue.

My Fairphone 2 which is running LineageOS 15 (Android 8.1) does not have this issue - can do AAC and LDAC.

I’m unclear as to what to do next.

Doing more research. This post about aptX on LineageOS seems related and seems to confirm what you’re saying, @JeroenH

I’m not happy with this outcome though. I’ve sent a support request.

Edit: Wikipedia says LDAC is open source and included in AOSP. So what you said about aptX doesn’t apply to LDAC.

Update: latest message from support:

I can confirm that HD codecs are not included at the moment.

I have been asking, every Monday, for updates on your other questions: I asked if we offer any alternatives and how to help you connect at a better quality, but, unfortunately, I still have no answer.

I will keep your request on hold until I have an answer.


Did you receive any update to this after two months? :slight_smile:

@aljoscha Nothing yet. I’ve asked for an update :slight_smile:


Here’s the relevant part of the response I received:

Unfortunately, so far I’ve received no reply. Today I have forwarded your question to our product again asking for an answer.
In a week I will contact you again and let you know if we are able to give you an answer or not.

1 Like

Update (3rd of June but I’ve been busy):

Some progress but no news yet.
Unfortunately, the older team leader of our product team, responsible for the Fairphone 3 project, after being with us for several years left the company after Fairphone 3 was released.

The current leader of the product team reached out to me telling me this matter will most likely be covered in a broader project over the documentation of all the processes leading to the creation of Fairphone 3. It will take some time as it is not a top priority at the moment, we are now talking about Q3 2020.

I’ve ‘snoozed’ the email till September, to remind me to follow up.


I have the same problem. Bought a pair of Apple AirPods Pro, but they sound like crap when making calls, and the person I’m speaking with can’t hear me well either, so I hope this can be fixed.

As I understand, we shouldn’t need to go into developer mode to change this. It should be available as a choice in the Bluetooth settings for each paired device.

Update (relevant parts + a typo corrected):

I apologize for the long wait and for the answer that will follow.
After my umpteenth request I have to accept that I am not able to satisfy your request, neither can anyone else.
Being still a small company we constantly need to reassess our priorities.

At this moment, we do not have the available resources to examine why, several years ago, someone made the decision to not include high-quality audio codecs. It might have been related to budget, it might have been an oversight as you suggested, or yet other reason.

Unfortunately, with our priority always shifting, we most probably will not be able to tell you, even the future. Considering this I will now close this ticket.


Thank you for following up on this! I’ve been keeping an eye on it and I find it amazing that my headset used to work in A2DP and since a few updates ago can only use HFP on Signal and such. You must be even more frustrated than I am. Thanks for posting this!

Fairphone 3+ user here (though probably not much longer). This is absolutely unbelievable. The device is not even two years old (was released in August of 2020) and they marketed it with software support for many years. Now they have somehow managed to remove features that Android should support by default anyway, stuff which you can usually get with the cheapest of the cheap android phones. I can’t even use AAC with my Sony WH1000MX4 headphones, something I have been able to do with just about all of my friends’ phones.

Essentially this makes my FP3+ worthless for me and many other people. Wireless headphones are established and will only continue to become more popular. Everyone who is even remotely into listening to music will not settle for SBC, just because FAIRPHONE can’t be bothered to implement stuff which just about every other manufacturer has been able to offer, and I’m talking about way cheaper phones here.

I have created a support ticket about this issue and will sell my FP3+ if it is not resolved (allthough I will feel bad about passing this problem on to someone else). It is such a shame, because in every other way I like this phone. But just arbitrarily not supporting stuff that it should is a complete dealbreaker and also a scary precedent for the future. Who knows what else they might just not feel like supporting in the future? I don’t want to be worried about features diappearing with every update.

If anyone from FAIRPHONE ist reading this: Do you guys understand how banal and ridiculous this is? Do you understand how many people use bluetooth headphones nowadays? Do you understand that Lineage OS, which officially supports your phones, supports all of these codecs? If your software team doesn’t know how to implement them, perhaps just ask the people at LOS? I refuse to switch to custom ROMs just because this company can’t be bothered.

As confirmed in your topic, AAC is available and working in general, just not with this headphone (dont know why) so saying they removed it is just not correct. I understand you are frustrated about this and I dont understand your comment above at all.

“unofficial” OSes can often implement things easier as they dont need Google or Qualcomm Certification and approval.

Edit: statement from FP2 LOS developer, so are you sure its implemented on the FP3 LOS, any proof you can link to?


As long as you explain the issue I see no problem in selling the phone.


Seconded. Bluetooth is such a traditionally unreliable technology, many people understand this and can’t be bothered to be grumpy about it. Just state the apparent incompatibility with your headphones model when selling the phone.


The way I see it, AAC is not really “working in general”, if it doesn’t work with a new headset from a major company which supports AAC and works flawlessly with just about any other phone I’ve tried it on. Also, I tried Valco’s VMK20, which also have AAC and it didn’t work either. It’s nice that somehow it works with the Bose Headphones, but a random chance is not “working in general”. It seems obvious to me that Sony and Valco haven’t implemented AAC in a way that somehow excludes Fairphones.

True, but the LDAC encoder is free and part of AOSP. It’s only the decoder that is proprietary, but that is done by the headphones themself. Also true, I have not yet installed FP3 LOS on this phone (and I most probably won’t), but I know from your other posts (thanks again) that you can use AAC and I have LOS 19.1 on another phone, where LDAC, AptX HD, etc. are all working flawlessly. Since AptX HD is a licencing issue, I wouldn’t be terribly surprised if the FP3 LOS didn’t have it, but it would blow my mind if someone had intentionally gotten rid of LDAC on that exact build for no reason.

The reason I am now more angry than a few days ago is that I can see in this thread that Fairphone has been aware of this bug (it is exactly that) for two years now and have basically stated that they just can’t be bothered to sort it out. It is maddening because they MARKET their phones as something people should use for a long time, but at the same time they won’t fix basic bugs. I have been telling just about everyone I know what a great phone this is, but if this is what one can expect on the software-side, it’s really sad. :frowning_face:

1 Like

I disagree. This is not an issue with Bluetooth or compatibility. The headphones are compatible and Bluetooth is working as it should. This issue lies entirely with Fairphone OS. It is a bug, plain and simple.

1 Like

This issue appears fixed for me with Android 11, at least with AAC (Bose Quiet Comfort 45).

1 Like

Probably not. If you read carefully, you’ll learn that the described problem has not occured with Bose, moreover it is stated, that Bose seems a bit of an exception as headphones of other manufactorers simply do not work.

Actually, the issue IS fixed as of now! At least for me on my FP3+ with my Sony WH-1000XM4 headset:

1 Like