English

Change Encryption to "new standard"

Hi,
I had used LOS 15.1 since today. I did an encryption back then and as I learned here, TWRP is unable to decrypt the data partition for Android 8/9 encryption.
I upgraded to 17.1 today using this version of TWRP, on which it it possible to decrypt the data partition.

Now the following questions arise for me:

  • Is it necessary to decrypt the data partition for the (daily) LOS updates?
  • And what about Open GApps?
  • Should I upgrade to the newest TWRP or can I use the custom version for future updates?
  • Is there a possibility to “upgrade” the “encryption standard” to what is used on Android 10 and can TWRP then decrypt the data? (sorry for my lack of proper vocabulary :sweat_smile:)
  • LOS offer their own Recovery image, but it is not supporting encryption if I understand correctly (My main problem is that I don’t have a spare SD card, and I cannot save the data on the phone outside the encrypted storage to be able to access it for flashing inside TWRP…)

Thank you very much for your help and have a nice day!
KJJ

You do not need encryption support in the recovery to do installs or updates.

Chris

3 Likes

“Possible” in the sense of “don’t count on it in practice” :wink: .

No. Encrypting “the phone” really only encrypts the data partition. Updates don’t affect the data partition.

Same.

Shouldn’t matter.

If anything, we could use a downgrade so that Android 9+ could handle an Android 7 encrypted data partition (Android 8 still could), then TWRP wouldn’t have a problem.

Any kind of solution is currently unlikely … the custom TWRP 3.2.3 was a good shot, I’ve seen it decrypting Android 8 encryption a few times myself, but never with a “real” installation with Apps and stuff, only in “lab conditions” with a freshly installed OS … and never Android 9.

1 Like

You are saying that official TWRP 3.3.1 can decrypt a LOS 17.1 encrypted /data?

What are you referring to?
Nobody said that.

Did you actually manage to encrypt your phone using LOS 17.1?
Everytime I tried, the phone just (soft) reboots and does nothing (apparently)…

@AnotherElk
That was what I read in the first post…

Please follow the “this version” link there … it doesn’t lead to official TWRP :wink: .

Thank you very much AnotherElk & chrmhoffmann!

Oh, it worked well for me. The decryption took a “long” time (approx. 10 minutes, I thought the app crashed - in the end it was successful) but I was able to navigate through the storage and install the LOS 17.1 update from the encrypted storage. In the future, I’ll consider that maybe I just got lucky.

Ah, okay, that makes sense!

Thanks again for your detailed answer! I think I will just leave it that way. My main concern is to be able to install updates, and thanks to the root access I can store the files necessary for the update in /cache, as lklaus mentioned here.

Have a nice day!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.