Certain apps keep crashing after first reboot

Not sure if this is the right category, please move accordingly. Also not sure if I should try to contact the people developing Lineage for FP2 directly, don’t know how.

Bought a used FP2 about a week ago, installed Lineage on it according to the official wiki via TeamWin, no Gapps this time around. Formatted the sd-card from my old phone as „internal“ storage. Everything is working fine except for a few very strange things:

  • Certain apps I install work correctly until I reboot for the first time. When I try to open them after rebooting they keep force closing („[Appname] keeps stopping“ etc.) until I reinstall them.
  • I’m pretty sure these apps are either installed on the sd-card or using them like Kiwix but also Pedometer which I don’t know why it would need the sd-card. Other apps that use the sd-card are working fine (e g. Signal which uses the sd-card for backups/imports etc).
  • All the misbehaving apps I’ve checked so far have „Samsung SD-Card“ as „Storage used“ in the app info. Trying to move to „internal“ storage results in a „Not enough storage space“ message (there’s about 7gb free space on the internal storage, that pedometer app is a few mb). Apps that are working fine can be moved from sd-card to internal without this wrong error message.

Things I’ve tried so far:

  • Clearing the cache/data of misbehaving apps
  • Wiping cache/ART/dalvik-cache
  • Booting the phone without an sd-card an reinstalling the apps. Result: apps crash everytime I try to open them.
  • Reinstalling Lineage (+___+)
  • Using another sd-card

After writing this I feel like this might either be a corrupted sd-card (unlikely that both my sd-card are corrupted and not sure how to check this) or a problem with Android/Lineage (or certain apps?) handling „internal“ and sd-card space.

Any ideas what I could try? (Accept for installing FPOS or FP Open and see if the problem persists…)

Mh, after reading this it might be that it’s the missing Gapps? Not for Kiwix though … And I’m using lots other apps that are flagged with using Playstore Services that work fine.

Have you tried using the SD card as “external” storage? Might be worth a shot.

CAUTION: you will lose data / have to reinstall apps when switching, so in any case do a backup of data / app settings you’ll want to keep before trying!

1 Like

Argh, yeah I have. Can’t remember what happened though :woman_facepalming: I feel like it was just like when booting without an sd-card, the apps just kept crashing after install. But that’s a thing I could try again, (and write down what happens this time around), thanks!

I’m gonna jinx it by saying this but: I did’nt to anything (except for a Titanium-backup!?) and the apps are behaving well, atm. Even Signal didn’t need to be re-registered as the default SMS app like after all the other boots …

So, I guess stay tuned until the problems resurface? :thinking:

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.